Yay error on install

I have tried to install something in the yay command. But i received the following error:

[~ ] $ yay -S signal-desktop-beta
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x60 pc=0x559e6587a5d1]

goroutine 51 [running]:
crypto/internal/nistec/fiat.(*P384Element).SetBytes(0xc00048a3c0?, {0xc000002157?, 0xb?, 0xc00048a3c0?})
	crypto/internal/nistec/fiat/p384.go:73 +0x31
crypto/internal/nistec.(*P384Point).SetBytes(0xc0004821c8, {0xc000002156, 0xc0004c0c28?, 0x126})
	crypto/internal/nistec/p384.go:64 +0x1f6
crypto/elliptic.(*nistCurve[...]).Unmarshal(0x559e65cb2680, {0xc000002156, 0x61, 0x126})
	crypto/elliptic/nistec.go:256 +0x7c
crypto/elliptic.Unmarshal({0x559e65caeb78, 0x559e65ed3ba0}, {0xc000002156, 0x61, 0x126})
	crypto/elliptic/elliptic.go:150 +0x2d1
	crypto/x509/parser.go:262 +0x4d5
crypto/x509.parseCertificate({0xc000002000, 0x272, 0x27c})
	crypto/x509/parser.go:923 +0x8c8
crypto/x509.ParseCertificate({0xc000002000?, 0x272, 0x34bf8?})
	crypto/x509/parser.go:985 +0x25
crypto/x509.(*CertPool).AppendCertsFromPEM(0xc000210ff0, {0xc000580000?, 0x31dc7ee96f5d6a82?, 0x4ed8aa4a391c0cb3?})
	crypto/x509/cert_pool.go:219 +0x118
	crypto/x509/root_unix.go:44 +0x1e5
	crypto/x509/root.go:30 +0x67
sync.(*Once).doSlow(0x559e657272df?, 0x559e6572ea2d?)
	sync/once.go:74 +0xc2
	crypto/x509/root.go:21 +0x50
crypto/x509.(*Certificate).Verify(0xc000478000, {{0xc00042c018, 0x11}, 0xc000210f60, 0x0, {0xc10f2b9189df9d91, 0x6223532c, 0x559e65f1efe0}, {0x0, 0x0, ...}, ...})
	crypto/x509/verify.go:787 +0x15e
crypto/tls.(*Conn).verifyServerCertificate(0xc000496000, {0xc000222540, 0x3, 0x4})
	crypto/tls/handshake_client.go:887 +0x719
	crypto/tls/handshake_client_tls13.go:477 +0x2ae
	crypto/tls/handshake_client_tls13.go:96 +0x239
crypto/tls.(*Conn).clientHandshake(0xc000496000, {0x559e65cadff0?, 0xc0004840a0})
	crypto/tls/handshake_client.go:228 +0x5ab
crypto/tls.(*Conn).handshakeContext(0xc000496000, {0x559e65cae028, 0xc0000b6000})
	crypto/tls/conn.go:1491 +0x32e
	net/http/transport.go:1544 +0x70
created by net/http.(*persistConn).addTLS
	net/http/transport.go:1540 +0x345

Have you tried signal-desktop instead of the beta version?

You can git clone the repo

git clone https://aur.archlinux.org/signal-desktop-beta.git

cd signal-desktop-beta
makepkg -sic
sudo make install

There are comments in the AUR saying the pkgbuild is incorrect because something was meant to go in the prepare section of the pkgbuild and didn’t. Thus it builds if you clone and makepkg, but not if you use an AUR helper.

oops, forgot the AUR url: https://aur.archlinux.org/packages/signal-desktop-beta

Yeah, the stable version on the oficial arch repo is correct, it installed correctly. But the problem seems to be in the yay program, not in the package I’m trying to install.

I doubt that yay is the problem. I use it every day. I have no issues with it.

Edit: As @svepp reported above

mkurz commented on 2023-01-21 20:00 (UTC) (edited on 2023-01-21 20:04 (UTC) by mkurz)

@Edu4rdSHL Thanks!

Just to let you know, it is not just a common issue across AUR helpers, putting the export into the prepare function is violating the PKGBUILD specification. prepare() is for preparing the source code, not doing something that is needed to build the package. Not just yay or paru fail, even a common use case for makepkg will fail when putting the export into the prepare() function like you did. Have a look at the makepkg manpage:

Huum, the usually update is normal. I think it’s correct, just this it showed the problem. So the problem must be occur just in some packages.

The person who created the package made some errors in the build from my understanding which makes it not work with any aur helper such as yay or paru etc. I’m not an expert on yay or package build but i use yay a lot and i have no issues with it if the download package is correct.

1 Like