YAD windows populate desktop

Is there any reason why I get this after a reboot?

Also I wonder why I need this “Warning” it does not make any sense to me :relaxed: I mean a ignorant user like me does not know what to “Continue anyway”, this feels like a bug to me. :woozy_face:
I’d prefer to have the WS opened even if no internet is connected. It may make more sense to open the WS and in itself there is a note that there is no connection.

Cheers!

If there is any need for logs, please instruct me where to find them. :smiley_cat:

Looks like a bug, strange. But thanks for the report!

Have you updated the system lately with

    sudo pacman -Syu

?

Basically only eos-update-notifier and welcome apps may give that warning window.
You can check which one by disabling either one of them:

    # run only one of these first
    eos-welcome --disable
    systemctl --user disable eos-update-notifier.timer

and reboot. Is the issue still showing?
They can be re-enabled by changing the disable word to enable in the commands above (and reboot).

Are you using KDE?
Are you using the save session feature?

Hi!

Thanks for your feedback!

Have you updated the system lately with

yes, I did -via pamac

I will try your suggestions, next time I reboot. Is this warning window coming from eos-updater?

Are you using KDE?
Are you using the save session feature?

Of course I use Plasma, what else :wink: :smiling_face_with_three_hearts:
And yes I use the save session feature. Could that be the reason for this YAD windows?

hello, as you are not connected “yad” tries to connect without being able to get there, yad gives the news archlinux.org

1 Like

@JR29
Ah…this is what YAD does. Thx!

1 Like

Seems that yad and the save session feature do not work well together. That problem existed already before, and a workaround was created. But apparently it doesn’t help the same way on all desktops.

So I have implemented another workaround for it, and will publish it in the next release as soon as possible.

That’s what disabling one of the apps should show us. :slight_smile:

1 Like

It comes up if your not connected to the Internet. So if you are on WiFi and it is taking a little time to connect this may come up because it’s checking before you are connected maybe?

Edit: As @JR29 has said.

2 Likes

@spacepig
Now welcome version 2.2.14-1 is released. Hopefully it solves most problems.

But please report anyway how it goes. :slight_smile:

2 Likes

Command “eos-welcome --disable”
Result:

Really strange.

What does command

    pacman -Q welcome

say?

Wait! I did not close the windows. I just rebooted…stupid me :partying_face:. Of course Plasma will recreate, them Let me re-check.

1 Like

I updated the Welcome package all works fine now!

->with eos-welcome --enabled, I had a opened “Warning” or a “WC-Screen” then I restarted the system. Result: no more YAD ghosts.
Still this “offine Warning” comes up.

Great! :smile:

Could you show the exact warnings?
Then it is easier for me to check where it is coming from.

Now it should show the source in the title of the warning window.

image
Here you are!

When that warning pops up do you have internet connected ? If you don’t then everything is working as it should, click “Continue anyway” and be done with it. WC screen needs internet connection to operate fully. “Continue anyway” should open WC screen if you are not connected.

If that warning pops up before your internet connects (WiFi) then that is something else, a delay setting would fix that.

My WC & notifier is working fine, hope it doesn’t get broke with all this updating stuff… :rofl:

1 Like

Check the middle box. " No internet connection" It’s running the process prior to an internet connection with WiFi.

1 Like

Oh dear!! @FastGame :smiley:
I clearly did not point out that my laptop takes a while until it is connected to wifi, I am so used to this slow connection behaviour that I consider it to be the-way-it-is™. Yes of course, you are right, I just get these messages when my system is still offine.
Sorry I was unclear in my initial report. :see_no_evil: I hope that @manuel, did not make you think that my system was online all the time. :sweat:

Still my guess would be that this “Warning” message will pop up for all offliners(?), it’s of course no big deal -> one click and it is gone. But it feels a little “un-expected” to see this pop-up.

It’s not a problem @spacepig. We all overlook things from time to time that are staring us right in the face. For me sometimes it comes from inexperience. Other times I’m just not paying attention and it doesn’t even enter my thought process. :wink:

1 Like

Indeed :smiley:
But you know when I see a “warning” message on my screen, I assume that there is a real thread somewhere -hiding in the bits and bytes, trying to kill my good old laptop :smiley:

1 Like

@spacepig
Thanks for the picture. It clearly shows that Welcome is giving the warning.
I’m making the warning configurable. Then user can choose whether welcome shows the warning or not.

2 Likes