Yad-eos and yad are in conflict

When I run yay I get

:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 endeavouros is up to date
:: Starting full system upgrade...
warning: cuda: ignoring package upgrade (11.2.2-1 => 11.3.0-1)
resolving dependencies...
looking for conflicting packages...
:: yad-eos and yad are in conflict. Remove yad? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: yad-eos and yad are in conflict
error installing repo packages

Try to remove yad I get

checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing yad breaks dependency 'yad' required by akm
:: removing yad breaks dependency 'yad' required by eos-bash-shared
:: removing yad breaks dependency 'yad' required by eos-update-notifier
:: removing yad breaks dependency 'yad' required by reflector-simple

I ran yay and removed yad as part of the update process. it all worked out OK!!

As I just found out yad-eos obviously is a dependency of eos-bash-shared. There seems to be no way circumventing this exchange if one wants to use some of the tools from the EOS Repository. The only thing would be to lock eos-bash-shared.

Edit : Pamac automatically switches packages.

Well, I will do your suggestion. I’m just afraid that removing yad will break something.

I just did sudo pacman -S yad-eos with the same result as mentioned above by @keithy. The process removed nicely yad with no other packages needing to be removed because of dependency on it.

we do currently using a patched version of yad yad-eos, it conflicts with the one from archrepo as it provides both yad :wink: so you should simple replace yad with yad-eos, till yad from archrepo gets fixed.

1 Like

I don’t think so. As far as I can see, nothing much has been changed. Just a little bit of code added. If problems will occur, going back is easy.

As @joekamprad already said, you should change yad to yad-eos.
yad-eos fixes one annoying issue with yad, the unnecessarily high window.

And if any problems occur because of it, please report to the EndeavourOS dev team as soon as possible! :wink:


the confusion starts because eos-bash-shared gets updated and it depends now on endeavouros/yad-eos instead of the default yad from archrepo what replaces community/yad

3 Likes

The same info is now available by clicking Welcome’s Software News button.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.