Xorg - Hotplugging warning Mouse lagging

does anyone have an idea where this the hotplugging warning and (EE) event2 is produced?

[     6.916] Current Operating System: Linux 6.0.1-arch2-1 #1 SMP PREEMPT_DYNAMIC Thu, 13 Oct 2022 18:58:49 +0000 x86_64
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     6.932] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[     6.932] (WW) Disabling Keyboard0
[     6.932] (WW) Disabling Mouse0
[     7.292] (II) Initializing extension MIT-SCREEN-SAVER
[  1440.037] (EE) event2  - Logitech USB Optical Mouse: client bug: event processing lagging behind by 22ms, your system is too slow
cat  /etc/X11/xorg.conf.d/20-nvidia.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 418.113

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
#    Option         "Device" "/dev/psaux"
    Option        "Device"      "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer K242HL"
    HorizSync       30.0 - 80.0
    VertRefresh     55.0 - 76.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 630"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option  "metamodes" "DVI-D-0: 1440x900 +0+768 {ForceCompositionPipeline=On}, VGA-0: nvidia-auto-select +40+0 {ForceCompositionPipeline=On}, HDMI-0: 1440x900 +1440+768 {ForceCompositionPipeline=On}"
    Option         "TripleBuffer"                  "on"
    Option         "AllowIndirectGLXProtocol"      "off"
    Option         "SLI" "off"
    Option         "MultiGPU" "off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Operating System: EndeavourOS
KDE Plasma Version: 5.26.0
KDE Frameworks Version: 5.99.0
Qt Version: 5.15.6
Kernel Version: 6.0.1-arch2-1 (64-bit)
Graphics Platform: X11
Processors: 8 × AMD FX™-8350 Eight-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GT 630/PCIe/SSE2
Manufacturer: MSI
Product Name: MS-7641
System Version: 3.0

best i could find so far

honka_animated-128px-35

1 Like