XFCE locks screen when receiving inhibit signal

Hey everybody, I just recently installed Endeavour, and up until this afternoon it has run absolutely perfectly. This afternoon I updated the system and since then have had issues with the screen locking at seemingly random intervals, much like the issue posted in October. I have been troubleshooting and ran the following command, as per a user on an arch forum: xfce4-power-manager --no-daemon --debug. After this I have recorded the output which is here in full: https://pastebin.com/syE8CpdB

My screen seems to lock almost every time i get one of these inhibit commands/signals from for example chrome. I have also experienced this with the AUR version of Slack and it’s notification sounds.

Does anyone know what might be the issue of this? Any help would be much appreciated. If you need any other logs just say the word.

first: welcome here at the forum!

Hard to say what is causing your issue, can be simple some misconfiguration on lock settings?

lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-' ix.io

would be more helpfull…

see here: https://endeavouros.com/docs/forum/how-to-include-systemlogs-in-your-post/

Thanks for the reply, here is the output of the command you suggested: http://ix.io/2dPY

You mention misconfiguration on lock settings but i do not believe i have changed anything other than setting values through power management GUI.

I hope the above log can help shed further light on the issue

I just tried rebooting and forcing it to lock me out, log back in and grab the systemctl log for the last 2 minutes, and it seems something horrible happens to the xfce-screensav application: http://ix.io/2dQ8

you can try disable screensaver in xfce4 settings!
and i do see this:

Mar 09 21:01:48 hojlind-t495 kernel: Uhhuh. NMI received for unknown reason 3c on CPU 0.
Mar 09 21:01:48 hojlind-t495 kernel: Do you have a strange power saving mode enabled?
Mar 09 21:01:48 hojlind-t495 kernel: Dazed and confused, but trying to continue

you can try using LTS Kernel to see if it is somehow related to kernel…

Screensaver was already supposedly disabled. I enabled and disabled it again, and also disabled “lock screen with screensaver”, this has resulted in the screen blinking black and then returning instead of locking. It seems like my disabling of screensaver is ignored.

I will try and install an LTS kernel and see if this makes a difference, will report back.

Thanks for the help so far!

Update: Using the LTS version does not make a difference, still seeing the same issue

sure that you change on bootmenu to boot on LTS? check on booted system with:

uname -a

Yes i am sure, it displayed in the grub menu and i reconfirmed by running

uname -r

However i looked trough my pacman log and went over the update from earlier today. One of the packages being updated was indeed the xfce4-power-manager as follows:

upgraded xfce4-power-manager (1.6.5-2 -> 1.6.6-1)

I just downgraded to the 1.6.5-2 package and the issue has disappeared.
I have marked this the solution however it would definitely be more interesting figuring out what is the actual issue. If i am the only one experiencing it however, i guess its on my side and i should do more digging if time permits.

1 Like

i see:

xfce4-power-manager 1.6.6-1

Last Updated: 2020-03-08 22:12 UTC

could be related to your CPU together with this update…
no BUG https://bugs.archlinux.org/?project=1&string=xfce4-power-manager
no issue at arch forum yet…

changes from last update:

1 Like

no BUG https://bugs.archlinux.org/?project=1&string=xfce4-power-manager

Yeah I checked too and didnt find anything, however I definitely feel too “new” and unexperienced to post a decent bug report, I feel like i would miss a lot of stuff.

If its specific to my cpu and not my system as a whole then there will probably be more people reporting the same issue soon.


lets wait 2 days and see if there will be some others reporting here or at arch… or may another update for xfce-powermanager will come up!

1 Like

probably related, but i am experiencing screen going black at random times after updating, moving the mouse restores the screen so its not something to do with cabling or monitor. power management is all disabled aside from turning off monitor 30 minutes after when idle (my usual setting)

[negative@endaevour ~]$ pacman -Qi xfce4-power-manager
Name : xfce4-power-manager
Version : 1.6.6-1

Hi Negative

Try running the following command and see if the issue stops, if this is the case then it is probably power manager related:

xfce4-power-manager -q

This does seem to be an issue as another user just reported it in another thread and i had him check and downgrade fixed the issue.

i have already downgraded to the version suggested here ( 1.6.5-2 ) and it still occasionally turns the screen black.

this seems to happen more consistently when opening discord, as soon as discord is launched, screen turns black. happens every other time e.g. launch discord, screen goes black. quit discord and launch it again its fine. quit discord launch it again screen goes black.

quiting xfce4-power-manager solves the problem in my case.

note “discord” is not the only app i notice this happen, screen goes black even when browsing, watching vids etc. its seems to happen with discord in a consistent basis so its kinda quick way to check (for me at least)

That sounds odd, but my experience was very similar, especially videos and notifications seemed to trigger it. It matched whenever an inhibit signal/command occured in the power manager debug log. I suggest creating a topic for your issue, that will probably get you better help.

its already on XFCE bug report with multiple confirmations

1 Like

Can you share the link!

Here you go: https://bugzilla.xfce.org/show_bug.cgi?id=16523

1 Like

is this still bothering anyone? another workaround is to remove screensaver if you have it installed…