Xfce lock screen flashes erratically

This might be useful for upstream xfce devs.

Sadly I am not that of an expert :sob: .

AFAIK and IIRC, some DEs (or systemd?) can handle these conflicts and won’t start an overlapping service. As you said, xfce is old and more free (allowing?) than others, so conflicts should be handled by the user (maybe?).
:slightly_smiling_face:

1 Like

but … i like to get you in on complicated cases… always brings in a clear view … and i believe you are an expert.

1 Like

would be the place to report…

There are several issues about the subject at xfce gitlab.
A nice one is this.

There is also a possible conflict with the autostarted programs (similar/same filenames).

Affected users might want to check which relevant programs (xflock, xfce-screensaver, xscreensaver, light-locker, etc.) are autostarted, and/or running in the session.
Maybe with

pgrep -a lock
pgrep -a saver
1 Like

if so mostt of them will be in /etc/xdg/autostart/

For me downgrading both
glib2 from 2.76.0-1 to 2.74.6-1
accountsservice from 22.08.8-3 to 22.08.8-2
fixes the issue

I updated glib2 on February 12 and accountsservice on February 13. On February 13 I noticed the issue described and first attempted to downgrade all packages I updated on the 13th. Nothing changed so I looked at the 12th and glib2 stood out so I downgraded that package and upgraded the packages from the 13th one by one until the problem showed up. The first package I upgraded ‘accountsservice’ broke my system so I surmised that the combination of glib2 and accountsservice was the culprit. I have since tested this ‘fix’ (downgrading both glib2 and accountsservice) on 3 laptops and 2 VM’s and the lock issue is fixed on all 5 systems. Note that 2 of the systems do not use xfcescreensaver, but all 5 use xflock4. Quickly tested by ctrl+alt+L to lock the system.

Today I noticed that accounsservice had an upgrade available (22.08.8-4) I tested in a VM if upgrading glib2 (2.76.0-1) and accountsservice (22.08.8-4) would fix this issue. It does not.

To summarize:
glib2 2.76.0-1 and accountsservice >= 22.08.8-3 cause the issue
glib2 2.74.6-1 and accountsservice 22.08.8.2 work fine

side note: to quickly downgrade a package use ‘sudo downgrade glib2 accountsservice’ to persist the downgrade add to /etc/pacman.conf (uncomment the line)
IgnorePkg = glib2 accountsservice
when permanent fix becomes available just comment the IgnorePkg line (should be commented by default)

1 Like

Your solution works for me:

  • Downgrade to glib2 2.74.6-1
  • Downgrade to accountsservice 22.08.8-2

Thank you!

Why do you think you were having the same issue?
What common system component do you have with the other posters’ systems?

This issue has become confusing IMHO, since random users with unknown systems post random experience.

I would suggest anyone that believes they have this issue, post system info, so we talk the same.
At least:

inxi -SMaz
pacman -Qs screensaver
pacman -Qs locker
pacman -Qs xfce

Also, part of journal log from a failing boot session might help (knowing we are talking about the same issue :person_shrugging: ).

FWIW, accountsservice is related to lightdm (not locking or screensaving) and merged support for lightdm recently.

For me, I don’t use XFCE as a DE. I only start xfce4-power-manager which starts xfce4-screensaver and xfconfd. And to rehash, when xfce4-screensaver is set to lock, I have the flashing problem.

I don’t use lightdm, doing xinit to login. So the locked screensaver is my only experience with this flashing issue.

I had this problem after my Sunday update, where I did get a new glib2 package. I did not get accountservice until a Monday update. I’d bet it’s just glib2, but don’t have time to try until later this week or weekend. If someone else has the time and experience level, would be interested to see.

For my screensaver needs, I’ve disabled my xfce4-power-manager and installed/using xscreensaver. MUCH better screensavers!! Screen DPMS, and screen locking! :slight_smile:

1 Like

Well, I am random, I suppose.

You are correct; I did not post in this thread information about my system, but I might yet do so, if doing so is important to solving the unique problems of other users, which may be different from my own.

No, my experience is not quite random. My experience is identical to the experience of the original poster in this thread, @andrewb, and to the experience of others who have posted here and in other threads.

FWIW, accountsservice is related to lightdm (not locking or screensaving)

I tried this solution:

  • Downgrade to glib2 2.74.6-1
  • Do not downgrade accountsservice

Upon rebooting, I saw only a black screen. Fortunately, going to TTY (Ctrl+Alt+F3) allowed me to restore glib to the current version and reboot successfully.

Then I tried @blue’s solution:

  • Downgrade to glib2 2.74.6-1
  • Downgrade to accountsservice 22.08.8-2

@blue’s solution worked perfectly. I saw the login screen and my previous session was restored.

I’m hoping that @blue’s solution will also work for someone else. If it doesn’t work for others, then we will still have learned something.

2 Likes

Finally, you added zero info to your previous post. Why?
Lot of effort hitting keyboard keys, but no effort to do as suggested.
Is it because of misunderstanding?

Thanks anyway. With your 2nd (identical) post, we now know you are still awake! :rofl:


No respect… chk, chk, chk… :disguised_face:

There is a new accountsservice package as of a few hours ago. accountsservice 22.08.8-4.

Anyone who has the problem want to try to -Syu and report back? I wish I could, but I’m super pressed for time and can’t -Syu given what may happen.

I just upgraded to accountsservice 22.08.8-4 (and at the same time restored glib2 to its latest version). Unfortunately, for me anyway, the new version of accountsservice did not solve the problem.

The only solution that works for me so far is to downgrade both glib2 and accountsservice:

  • Downgrade to glib2 2.74.6-1
  • Downgrade to accountsservice 22.08.8-2
1 Like

the issue does seem to lie with glib2, however downgrading glib2 and NOT downgrading accountsservice causes accountsservice to not start on boot causing a black screen and inability to continue boot process. I had to downgrade both in order to have a working system without the erratic lock screen. accountsservice >= 22.08.8-3 seems to require glib2 2.76.0-1 to function properly?

as stated in my original post accountsservice >= 28.08.8-3 (I tested 28.08.8.4 before I posted) with glib2 2.76.0-1 causes erratic lock screen behaviour. accountservice >= 28.08.8-3 (including -4) without glib2 2.74.6-1 causes broken boot.

I had the exact same issue / configuration as OP. I have 2 laptops using xfce4-screensaver configured to lock the screen after a set time. I have a 3rd laptop without xfce4-screensaver turned on. All 3 machines had erratic lock screen behavior if locking screen manually or with screensaver activation (2 machines). All 3 machines lock screen work as expected when downgrade BOTH glib2 and accountsservice (as stated above, accountsservice breaks boot if not downgraded with glib2)

I just did a default offline install of EndeavourOS using EndeavourOS_Cassini_neo_22_12.iso (the iso I had available) in a VM. Performed a full upgrade via yay (252 packages including glib2 and accountsservice). Reboot and ctrl+alt+L to lock the system (screensaver is not active by default) and got erratic lock screen behavior. Downgrading both glib2 and accountsservice as stated in my original post fixed the issue. I cannot speak to other DE or locker programs, xfce4 uses xflock4 btw. But the issue exists in default basic install and upgrade of EndeavourOS. In my limited testing the issue seems to lie with glib2 2.76.0-1 (and accountsservice >= 22.08.8-3 since downgrading glib2 without also downgrading accountsservice breaks boot process since accountsservice fails to start)

added: downgrading glib2 2.74.6-1 and leaving accountsservice 22.08.8-4 does not completely break boot. It just takes long time. Also once logged in it takes >=5 minutes for wallpaper to show up.
Accounts Service fails (accounts-daemon.service) with: /usr/lib/accounts-daemon: symbol lookup error: /usr/lib/accounts-daemon: undefined symbol: g_string_free_and_steal
ctrl+alt+L to lock screen causes an issue with the unlock dialogue box taking over a minute to appear. Able to unlock normally (no erratic behavior) accountsservice 22.08.8-4 (with downgraded glib2 2.74-6-1) stops the erratic lock screen but causes issues of its own.

3 Likes

Oh noes, that’s a bummer. Thanks for trying.

I’m using xinit and it’s startx script to launch my twm and more, and instead of lightdm. Screen i handled with the xscreensaver package, which does lock my screen.

For those on laptops, a combo tool like xss-lock and slock may work if you shut your screen. YMMV.

1 Like

I have already looked. There is only one active screensaver process.

2 Likes

Should be fixed in a few days in master https://gitlab.xfce.org/apps/xfce4-screensaver/-/issues/119

2 Likes

I wonder if xfce4-screensaver issue #119 is the same problem that’s hitting a number of us. I never got a core dump.

Fixed on master by 7aeced1f, I’m glad I took care of it (it wasn’t crashing yet at that time). It’s an old error, but the update of a lib (GLib ?) must have woken it up :slight_smile: There should be a version 4.18.0 in not too long I think.

so check the git AUR build:
https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=xfce4-screensaver-git

should include this change if you freshly build directly from git

1 Like