Xfce lock screen flashes erratically

Fixed on master by 7aeced1f, I’m glad I took care of it (it wasn’t crashing yet at that time). It’s an old error, but the update of a lib (GLib ?) must have woken it up :slight_smile: There should be a version 4.18.0 in not too long I think.

so check the git AUR build:

should include this change if you freshly build directly from git

1 Like

Good find and thanks.

“old error”? A skeleton in the XFCE closet codebase. I eagerly await a new xfce4-screensaver package, but wonder aloud if such will fix the users who saw flashing while logging in.

While I still really like XFCE but rarely use it, this incident has bumped up the priority of mine to trial and eval icewm.

1 Like

just find something that hangs in the closet since the 90ies :wink:


I have the same problem. Temporarily abandoned the stock application.

I use normal Rollig release of EndeavourOS, if xfce4-screensaver is outdated, can not be shot from repos or install the light-locker for xfce installation as default ?

we could the git build asa package on EndeavourOS repository. This is a snapshot from the source repo.

the package on arch repo is already marked out of date:
Flagged out-of-date on 2023-03-18


because new release is out yesterday:

So it will get updated in the next days…

1 Like

Today did an update and among them was libsoup3 3.4.0-1 (from 3.2.2-1) and my virt-manager broke in that I could not open any VM’s (cli with virsh still worked fine). Downgraded libsoup3 back to 3.2.2-1 and virt-manager worked again. libsoup3 3.4.0-1 had changes that depend on glib2 2.76.0-1 so keeping all these packages downgraded is getting to be a messy solution.

to fix install xfce4-screensaver-git (should automatically remove xfce4-screensaver)
if downgraded glib2 (2.74.6-1) and accountsservice (22.08.8-2) upgrade them both and enjoy functional lock screen behaviour.

Another solution is to remove xfce4-screensaver and install light-locker as suggested:

explaination: xfce4 uses xflock4 to handle screen locking. xflock4 is a bash script that calls in order: xscreensaver, light-locker, xfce4-screensaver and launches the first of those it finds. Default installs of xfce have xfce4-screensaver installed so that is what gets launched and erratic lock screen behaviour follows since xfce4-screensaver has not been updated to reflect changes in glib2. Remove xfce4-screensaver and install either xfce4-screensaver-git or light-locker to fix. No need to downgrade any packages as I suggested earlier.


yes and lets hope the updated xfce4-screensaver will reach repos soon …
downgrading essential stuff like glib2 is never a save solution indeed… only a workaround

The link

Does not go to the correct website. Uses https://forum.endeavours.com/ instead of https://gitlab.xfce.org/

correct link: https://gitlab.xfce.org/apps/xfce4-screensaver/-/commit/7aeced1f6fb39fd8887fc441b4ff491ba5bfcf35

Downgrading packages in general is never a safe solution :stuck_out_tongue:

In any event I am glad you found that fix in the git repo. I don’t mind using light-locker but would rather have the screensaver (slideshow)

General advice and kind of off topic, if you do have to downgrade a package or a couple packages due to issues, best bet is to pause further updates until those issues get resolved.

For me, the issue goes away if I temporarily turn off one of my two monitors. So as a workaround, I can turn it off, make it through the lock screen, and then turn my second monitor back on afterwards.

I’m visiting here from ArcoLinux Land :slightly_smiling_face:
I was having this issue and this thread helped me with figuring out a workaround so I thought I’d leave it here as well. At least for me, using the newer 4.18 version of xfce4-screensaver seemed to fix the issue. To install it from the Arch testing repos:
sudo pacman -U https://archive.archlinux.org/packages/x/xfce4-screensaver/xfce4-screensaver-4.18.0-1-x86_64.pkg.tar.zst

I know this is not ideal as you’ll have packages out of sync, but so far, it has been working for me, until the rest of Xfce 4.18 lands in the main repos.


My Arch mirror (top secret, hehe), has a package waiting for me, being 4.18.0-1 of xfce4-screensaver

Time to -Syu for anyone who hit this, assuming your mirror is up to date.

Fixes the issue for me with 4.18.0-1. It just hit Manjaro Unstable branch. As an added bonus, I checked out my .xsession-errors and I found out that my autostart script that I have been using to lock the screen with xfce4-screensaver was no longer working. I was getting the following:

 06:42:36.868: Unable to launch "/bin/autolock" 
(specified by autostart/autolock screensaver.desktop): 
Failed to execute child process “/bin/autolock” (Permission denied)

I removed the script and the autostart entry and xfce4-screensaver no longer has an issue with locking the screen after a set time.

For me, xfce4-screensaver 4.18.0-1 solves the problem being discussed in this thread: boot-up after suspend or hibernate displays a blinking, nonfunctional login screen.

Unfortunately, for me, the update introduces a new problem: I am not able to switch reliably between users after hibernation. (Correction: See Edit below.)

For one example (and I’m experiencing other anomalies, too): User 1 hibernates. Upon reboot, User 1 switches on the login screen to User 2 (without logging in as User 2) and then switches back to User 1. Logging in at this point as User 1 fails the first time but succeeds the second time (and, upon second login, User 1’s previous session is properly restored). (Also irritating: Switching between users on the login screen after hibernation used to require only a simple press of the up or down arrow key, but it now requires a press of a new Switch User button.)

Since two users use my computer, I’m reverting for now to the previous workaround.

Edit: The previous workaround is actually worse than the upgrade to xfce4-screensaver 4.18.0-1, since the previous workaround doesn’t even offer the option of switching between users after hibernation.

what exactly refering it to?

Sorry, I wasn’t clear. What I call the previous workaround is the solution offered by @blue:

  • Downgrade to glib2 2.74.6-1
  • Downgrade to accountsservice 22.08.8-2

However, see the Edit to my previous post. This new upgrade may be better for most users, as it at least allows a (buggy) switch between users after hibernation:

  • Upgrade to xfce4-screensaver 4.18.0-1

So, I favor the new upgrade.

yes downgrading can only be an “in a hurry workaround”

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.