Xfce/i3 Welcome App keeps popping up

I installed & setup Endeavour Xfce/i3 and for some reason the welcome app keeps popping up after each reboot, even after i select “Don’t Show me anymore” & Firefox Auto launches with it. Not sure IF the 2 are related? Thanks!

Have you got a saved session that is reopening applications from some point in the past (or automatically saving running applications when you log out)?

Not that I’m aware of, on install i selected auto login other then that i have no saved session.

Edit: IF i removed it from Session and Startup under “Application Autostart” would that work? "Welcome (EndeavourOS Welcome Launcher)

Maybe. You are using xfce with the WM replaced by i3. I think you need to make an i3config edit. I have the same setup installed here so let me test it out.

# dex execute .desktop files
# keep in mind that it can cause issues 
# when second to i3 a DE is installed or mixed usage of i3 + xfce4 or GNOME
# in this cases better disable dex and use manual starting apps using xdg/autostart
#exec --no-startup-id dex -a -s /etc/xdg/autostart/:~/.config/autostart/

Yes. In session and startup, anything that is checked will startup. Maybe i3/xfce broke the welcome app dismissal GUI. Let me know if it fixes it, and I’ll add that to the tips & tricks.

I didn’t have that issue, BUT since I hate that thing, I may have unchecked that when I was doing the initial process adding in i3wm to session startup. I always do it, and knowing me, I probably did it at the same time when I killed off xfwm4.

1 Like

Ok I removed from Session and Startup under “Application Autostart” "Welcome (EndeavourOS Welcome Launcher), it worked now i just have to stop Firefox from auto launching.

1 Like

I will note this in tips & tricks that if you would like to “dismiss the welcome app” manual intervention would be required.

Thanks again for testing this! Since this isn’t really a sanctioned DE or directly put together this way, there’s bound to be nuances that come up.


Editing the config as above works as well. Afterwards when you tell welcome to not show anymore it will stop on the next reboot. probably on a log out log in as well.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.