XFCE Doesn't Load Correctly After Installing Nvidia drivers

I recently installed Nvidia drivers with nvidia-installer-dkms and while my system boots into the default XFCE interface with the mouse wallpaper just fine, it doesn’t do the next step up loading my panel or endeavour wallpaper. Any help with this would be appreciated. I can provide any logs necessary, I’m just not sure what’s helpful for this.

Welcome to :enos: forums!!
You can read this article for instructions on how to submit logs:

Thank you for the welcome!

I realize my original post was slightly ambiguous. I did find the log sharing tool in EOS, which I think is really, really cool. I’m just not sure which logs will be useful for troubleshooting this issue.

These two to start with:
Hardware information:

inxi -Fxxc0z --no-host | eos-sendlog

Boot log:

journalctl -b -0 | eos-sendlog

inxi -Fxxc0z --no-host | eos-sendlog:

journalctl -b -0 | eos-sendlog:

So the desktop loads but has the vanilla Xfce background? It is working i take it though? Have you tried using the welcome app and loading EndeavourOS default wallpaper?

Edit: It doesn’t load the bottom panel?

Correct, EOS loads but it gives the default xfce wallpaper with no panel. I have to right-click to open anything. I’ll see if I can open the welcome page.

Welcome to the forum @d0c_z3r0d4y :enos: :enos_flag: :partying_face: :tada: :balloon:

Thank you!

Okay, just gave it a try. I am able to set the wallpaper through the welcome app. I then hit the “Xfce EndeavourOS default theme” button and restarted. It seems to be loading properly now. Unfortunately, my previous panel settings were overwritten, but I’ll count this as a success. Thank you for the help! How should I mark this as closed?

Select the post the solved the issue. Click on the three … and then solution.

Awesome, thanks for the help! Great community y’all have going here :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.