Xed: missing libraries

xed came preinstalled with i3wm. Whenever I run xed I get the following warnings:

Error loading plugin: libhspell.so.0
Error loading plugin: libhunspell-1.7.so.0
Error loading plugin: libnuspell.so.5
Error loading plugin: libvoikko.so.1

xed appears to perform just fine. I haven’t tried any spelling though

I reinstalled xed, but nothing changed.

I installed hspell, hunspell, nuspell, and voikko and the warnings disappeared.

Why does the live-environment not have those installed?

Possibly you don’t have package gspell installed.

Note that you can check the dependencies of a package with command

pacman -Si "package-name"

Try in Edit- Preferences-Plugins and uncheck spell checker etc., if you don’t want to install any of the plugins. I have the following in my plugins folder:

/usr/lib/xed/plugins/bracket-complete/bracketcompletion.plugin
/usr/lib/xed/plugins/bracket-complete/bracketcompletion.py
/usr/lib/xed/plugins/docinfo.plugin
/usr/lib/xed/plugins/filebrowser.plugin
/usr/lib/xed/plugins/joinlines.plugin
/usr/lib/xed/plugins/joinlines/__init__.py
/usr/lib/xed/plugins/libdocinfo.so
/usr/lib/xed/plugins/libfilebrowser.so
/usr/lib/xed/plugins/libmodelines.so
/usr/lib/xed/plugins/libsort.so
/usr/lib/xed/plugins/libspell.so
/usr/lib/xed/plugins/libtaglist.so
/usr/lib/xed/plugins/libtime.so
/usr/lib/xed/plugins/libtrailsave.so
/usr/lib/xed/plugins/libwordcompletion.so
/usr/lib/xed/plugins/modelines.plugin
/usr/lib/xed/plugins/open-uri-context-menu/COPYING
/usr/lib/xed/plugins/open-uri-context-menu/open-uri-context-menu.plugin
/usr/lib/xed/plugins/open-uri-context-menu/open-uri-context-menu.py
/usr/lib/xed/plugins/sort.plugin
/usr/lib/xed/plugins/spell.plugin
/usr/lib/xed/plugins/taglist.plugin
/usr/lib/xed/plugins/textsize.plugin
/usr/lib/xed/plugins/textsize/__init__.py
/usr/lib/xed/plugins/textsize/documenthelper.py
/usr/lib/xed/plugins/textsize/signals.py
/usr/lib/xed/plugins/time.plugin
/usr/lib/xed/plugins/trailsave.plugin
/usr/lib/xed/plugins/wordcompletion.plugin

these are optional spellcheck plugins and as xed is GUI app it is usually started from the menu mod+d (rofi menu).

It depends only directly on gspell what is installed.

1 Like

Thanks to all for your responses.

I re-installed i3wm. When I started xed, I had the warnings I mentioned above show up.

My first step was to follow jrichard326’s advice. The warnings disappeared when I deselected spell checker on the plugins preference. Since I won’t be using xed for anything that requires spellchecking, this solution works for me.

I reselected spell checker on the plugins preference, and got the warnings back. Then I installed gspell. It turns out, gspell was already installed, so I was stuck with the warnings.

Unchecking the spellcheck plugin worked!

Thanks again to all who helped me

yes is partly simple bad defaults on xed not sure if we can do anything “downstream” but I will check.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.