Xbox Elite 2 controller seen on scan but failing to connect

This post has been heavily edited from its original as i’ve made more discoveries

I am attempting to wirelessly connect my Xbox One Elite Series 2 controller via bluetooth, and neither the KDE GUI bluetooth utility nor bluetoothctl can see it during a scan.

  • When scanning with my iPhone bluetooth menu, it is immedately discovered in iOS

  • I am able to pair other bluetooth peripherals without issue

  • I have attempted to connect with both xpadneo-dkms and xpadneo-dkms-git installed. No, not at the same time.

  • bluez, bluez-utils, all of the usual bluetooth packages are installed and appear to be working fine.

  • I have only had this issue since a fresh install where I switched to BTRFS and Zen kernel. I’ve never had this issue on any of my prior EndeavourOS installs, or on any other distro I’ve used in the past

  • I have factory reset the xbox controller multiple times. My iPhone can still see it, my laptop still cant, even though it has no issue detecting other bluetooth devices

Any help you fine folks can provide would be much appreciated.

A month or so ago i updated my Elite 2 to the latest firmware as i was experiencing some issues on windows with it and since then it does not connect to EOS… the update definitely broke something.

I haven’t even connected mine in like 4 months, and it’s only ever connected to this machine on various Linux distros, I don’t own an Xbox or windows machine. If there was an update I don’t think I received it.

I’m guessing you already tried this but can you try repairing by holding the xbox logo and the pair button until the logo button starts blinking ? and then waiting until on the “add bluetooth device” window a controller appears, if I remember correctly for me it used to take 30sec - 1 min until it appeared there… also are you sure that this 8C-42 is the controller ?

can you also try the commands bellow

bluetoothctl scan on

See my update above, no, I don’t think that address is the controller, because it already popped up in bluetoothctl scan without the controller being turned on.

about to try your reset…

So. . . I’ve been having an atrocious time recently connecting my controller, even with xpadneo. I started looking at other options.

This literally just arrived at my door. Within 2 minutes I was paired with it. I stuck it in a usb port on my computer (Fedora), hit the pair button on it, same with controller, and it just worked. I don’t know what voodoo they did to make it work, but it says it works on steam and raspberry pi, so I got it. $16, and if I never have to deal with xpadneo and non-sense ever again, it’ll be worth every penny.

It all boils down to some chips are just garbage! :wink:

Ya, the one in the stupid microsoft controller. I wish it wasn’t so much better than every other controller I’ve ever held. It’s so nice.

You can’t just use one command and think it’s going to connect. Go through all the steps with bluetoothctl.