Xbacklight not working on Plasma KDE

Recently, the nvidia drivers got updated, and that broke my brightness controls I believe.

Before, the Increase and Decrease Screen Brightness shortcuts under Settings > Shortcuts > Power Management didn’t work either, and I got around it by setting custom shortcuts that executes the commands light -A 8 and light -U 8 respectively (I think xbacklight wasn’t working then too).

But now, light doesn’t work either now as well, so I believe I want to solve two problems:

  1. How to resolve xbacklight not working? (extra info: just running xbacklight or sudo xbacklight gives no output, I also have xorg-xbacklight installed. I also tried tweaking the kernel parameter acpi_backlight to all of video, native, vendor, and none of them worked)
  2. How to resolve the keyboard shortcut of Increase and Decrease Screen Brightness? This is more minor, but I would like it solved since my current shortcut to brightness is Ctrl+Fn+F5 and Ctrl+Fn+F6, which I think is janky.

There were some recent kernel changes in the back end of the brightness APIs which likely broke older programs/utilities.

You may want to check out AUR for brightness and acpilight packages as alternatives.

Yeah I’ve tried both of those too, and both didn’t work.

brightness doesn’t do anything when run in command line
I did the setup portion in the acpilight github readme, but still I wasn’t really sure what that was meant to do? There was no acpilight command available even when I restarted my system.

Which kernel are you on? uname -a

If on linux, maybe attempt installing linux-lts and rebooting into it to see if you hit a kernel regression.

Linux ideapad 6.1.22-1-lts #1 SMP PREEMPT_DYNAMIC Thu, 30 Mar 2023 14:10:04 +0000 x86_64 GNU/Linux