X11 Login will break same Login with Wayland (eventually)

Has anyone noticed if you use Wayland, then decide to login to X11, it works, but if you try and log into Wayland again, it breaks Wayland login (may take couple attempts before it breaks)

I created a pure Wayland testing account and have only logged into Wayland and it continues to work fine.

I’m wondering what FILE is being adjusted by X11 that breaks Wayland login and if its possible to fix this, maybe by just copying the wayland touched file to the X11 login account to fix Wayland use on said account.

Anyone have information on this? I do believe this could be a Plasma bug as I’ve tested Gnome Wayland on a X11 account without issue.

I should note I’m using NVIDIA GPU so maybe its related, but I don’t see how.

There are several bugs reported upstream.

I suggest you look for one that is similar to yours, and/or see how others try to troubleshoot and provide logs to the KDE devs.

1 Like

Turns out, its related to the above 75hz bug in nvidia 525 and 530 drivers. You can test this by generating a NEW ACCOUNT and then login, this should work as it defaults to 60hz, change refresh rate to above 75hz (I have 120hz), then log out and try and log in again, blank or frozen screen and system becomes unresponsive.

I have tried 525 and 530 driver and it appears to be present in both for me. Also I run a dual monitor setup, but changing the first monitor to above 75hz is enough to trigger the bug.

I do not know when NVIDIA plans to fix this, its quite frustrating. Also its possible 525 driver works ok under Gnome-Wayland but not Plasma. Lots of wayland and nvidia bugs to go around lately!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.