X11 KDE triggers kernel error

This is a very strange thing that only started to happen last night, and 100% triggers since last night.

What triggers it?

  1. Login from SDDM, to KDE desktop, only X11 is affected.

What is the symptom?

  1. Kernel panic in log. (Link to full log below)

  2. My computer can’t no longer shutdown, doesn’t matter if I try from SSH (sudo reboot or sudo poweroff) or physical power button.

  3. Monitor output is cut, shortcuts to switch TTY doesn’t help.

What have I checked?

  1. Boot from Live USB is fine, I can do video playback so I think my GPU is fine. (I am not sure if Endeavour OS live USB uses Wayland or not)

  2. I installed plasma-wayland-session and I can login to desktop by using Wayland.

  3. Switched kernels: Xanmod (which I used), Arch linux “linux” kernel , “linux-lts” kernel. Can trigger on all three.

  4. “sudo paccheck --list-broken” outputs nothing.

  5. …It is not triggered on new account, something is weird about my user profile.

Log with “-p 3”:

Full logs:

Can you post the output of:

journalctl -p 3 -xb

save us wading through all the journal, thanks

1 Like

Here is the log, thanks.

Looks like its something to do with your gfx card drivers, if you have an amd card I believe they are included in the kernel, have you tried an lts kernel?

maybe the last kernel update broke the amd driver!?

Yes I have a AMD RX560 GPU and the log is from LTS kernel, the kernels I used were:

Xanmod 5.13.6-2 (still not fixed in 5.13.8-1)
Linux 5.13.7
Linux-lts 5.10.55

Unless somebody else with more amd knowledge jumps in

Have a look through this:
https://wiki.archlinux.org/title/ATI
especially this:
https://wiki.archlinux.org/title/ATI#Troubleshooting

1 Like

@axzxc1236

OT

Sorry for the OT question. I don’t seem to find this command line on my system. Could you please point me to where I can find it?

sudo paccheck --list-broken
        
sudo: paccheck: command not found

It’s part of the pacutils package.

1 Like

Thank you so much! I appreciate it.
:wave:t5:

Do you have virtualbox installed? Is the KDE problem booting on the installed system or in v-box?

Edit: On the installed system could you post a link to the output of

inxi -Faz --no-host | eos-sendlog

the full boot log would be good to see and the hardware info from inxi command @ricklinux give before, the DRM errors looking like a gpu-driver-kernel issue to me…

journalctl -b -0 | eos-sendlog

i do like long logs | i can parse them

It might be nice to also see

sudo dmesg | eos-sendlog

Yes I had virtualbox installed, because I wanted to use Genymotion a few months back (the aur package instructed me to load kernel modules at start because it runs on Virtualbox)

This Linux installation is running on bare metal.

I had virtualbox removed before generating the following logs.

Log of “inxi -Faz --no-host | eos-sendlog”: https://clbin.com/2fups

Log of “journalctl -b -0 | eos-sendlog”: https://clbin.com/PCyDo

Log of “sudo dmesg | eos-sendlog”: https://clbin.com/ZZpzR

I notice you have the following kernel parameter. libahci.ignore_sss=1 Haven’t seen that one before. Is it really necessary? What is the reason you are using it?

Your graphics card is GCN4 so it should be using amdgpu. I see it loading ati under display x11?
I have xf86-video-ati loaded on my system with RX590 but it uses amdgpu for all drivers.

I did notice one warning message in dmesg. Not sure it’s causing a problem. It’s also in the boot log. This error message is common even on the RX 5700 XT

WARNING: CPU: 9 PID: 697 at drivers/gpu/drm/amd/amdgpu/../display/dc/core/dc.c:922 dc_commit_state+0x86a/0xa30 [amdgpu]

I didn’t really see anything that pops out in the boot log on the lts kernel or the other logs either. I didn’t see any kernel errors in the boot log. Maybe @joekamprad might get time to look at them but he’s pretty busy right now!

The boot log looks pretty normal to me. I see your Bios is the latest.

About the “libahci.ignore_sss=1” line, it’s taken from here because I have external HDDs that I sometimes plug in.

By error message I means lines like

“[drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] ERROR [CRTC:52:crtc-0] flip_done timed”

“[drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] ERROR [CRTC:52:crtc-0] flip_done timed out”

I didn’t see those error messages in the boot log so they must happen when using the system?

… yes in this case “use” is login into KDE environment.

The problem is solved, thanks for mentioning xf86-video-ati, I removed it and installed xf86-video-amdgpu instead and after reboot I can use X11 again.

Okay that’s great because i also use KDE and i have RX 590 using andgpu. Your card is GNC4 which also uses amdgpu and you can also use amdgpu pro. I have never tried it as everything works fine on amdgpu.

Hmm… looking at my pacman log my xf86-video-amdgpu package is removed back in Feburary, I wonder why my system ran fine until two day ago then it went bad.