X server freeze randomly

On my new laptop I am noticing that every now and then the X server freezes completely, the screen doesn’t refresh, and any form of input seems to have no effect. This happened with TeamFortress2, IronSnout but also while watching a video on youtube with Firefox. I have already looked for possible solutions but I don’t even know where to look for the information necessary to understand what problem I am experiencing. Please help me.

Hello @Airax

Please look over the wiki so you can provide the relevant information.

You could start by providing your hardware information.

inxi -Fxxxz --no-host

Please make sure to put ``` before and after what you paste so it is readable.


Here the information about the hardware I use:

System:    Kernel: 5.10.7-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: bspwm 0.9.10 info: polybar dm: startx 
           Distro: EndeavourOS 
Machine:   Type: Laptop System: TUXEDO product: TUXEDO v: N/A serial: <filter> Chassis: Notebook type: 10 serial: <filter> 
           Mobo: TUXEDO model: N141CU serial: <filter> UEFI: INSYDE v: 1.07.07RTR1 date: 11/08/2019 
Battery:   ID-1: BAT0 charge: 34.9 Wh condition: 35.9/35.3 Wh (102%) volts: 13.0/11.4 model: Notebook BAT type: Li-ion 
           serial: <filter> status: Charging 
CPU:       Info: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP arch: Kaby Lake note: check rev: C 
           L2 cache: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36812 
           Speed: 811 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 811 2: 804 3: 808 4: 806 5: 808 6: 806 7: 848 8: 821 
Graphics:  Device-1: Intel UHD Graphics vendor: CLEVO/KAPOK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9b41 
           Device-2: Chicony Chicony USB2.0 Camera type: USB driver: uvcvideo bus ID: 1-7:2 chip ID: 04f2:b649 
           Display: server: X.org 1.20.10 compositor: picom v: git-dac85 driver: intel unloaded: fbdev,modesetting,vesa 
           resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:02c8 
           Sound Server: ALSA v: k5.10.7-arch1-1 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK driver: r8168 v: 8.048.03-NAPI 
           port: 4000 bus ID: 3b:00.1 chip ID: 10ec:8168 
           IF: enp59s0f1 state: down mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 4000 bus ID: 40:00.0 chip ID: 8086:2723 
           IF: wlan0 state: up mac: <filter> 
Drives:    Local Storage: total: 232.89 GiB used: 33.39 GiB (14.3%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO M.2 250GB size: 232.89 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 4B6Q 
Partition: ID-1: / size: 227.94 GiB used: 33.39 GiB (14.6%) fs: ext4 dev: /dev/sda2 
           ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 45.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 209 Uptime: 2m wakeups: 1 Memory: 7.47 GiB used: 1.09 GiB (14.6%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 Packages: pacman: 894 Shell: fish v: 3.1.2 running in: termite inxi: 3.2.01 

Here is the journal log of the last boot with a freeze: http://ix.io/2MoE

I wonder if it’s because it’s using Intel instead of modesetting kernel module for graphics.

To see which video drivers are installed, please show the output of command

 pacman -Qs xf86-video

That’s the output of pacman -Qs xf86-video:

local/xf86-video-fbdev 0.5.0-2 (xorg-drivers)
    X.org framebuffer video driver
local/xf86-video-intel 1:2.99.917+916+g31486f40-1 (xorg-drivers)
    X.org Intel i810/i830/i915/945G/G965+ video drivers
local/xf86-video-vesa 2.5.0-1 (xorg-drivers xorg)
    X.org vesa video driver

I guess I’m using intel drivers

I have the same issue that started about a week ago. Sometimes it resumes after ~1 minute, but most of the times I have to restart the system completely.

You could try uninstalling the xf86-video-intel driver and see what happens after reboot.

But before doing that, make sure you have the USB installer stick available (and in working condition) in case you have problems booting. If you are unfamiliar with chrooting, you should read this: https://endeavouros.com/docs/system-rescue/rescue-non-booting-system-with-arch-chroot/

Welcome aboard! :smile:
Do you have a similar graphics system, or something else? To keep threads easier for future readers, you could start another thread if the suggestions presented here do not help.

I just uninstalled it and the pc booted up without problems. Now I try to trigger the freeze.

1 Like

I tried both IronSnout and TeamFortress2, which were the two games where the freeze occurred and there seems to be no problem, everything went smoothly, indeed TeamFortress2 seemed smoother. At this point I believe that the problem can be considered solved.