wxLua - cannot get it to work

10:36:10: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1014,wx containers,compatible with 2.8).

The library used 3.0, my program uses 3.0 !!!

Been banging my head against this for more than a week, can anyone point me in the right direction?

Could this difference be the reason?

Probably, but I have recompiled everything, tried third party repos and failed :frowning:

Do you have more than one version of wxwidgets installed?

In Arch I find
## wxlua
## wxlua-git 1:

I have wxgtk2 & 3 installed as dependencies for other programs:

yyl wxwidget
 1 extra/wxgtk2 [installed]
 2 extra/wxgtk3 [installed]
 7 alerque/wxlua [installed]

yyl is an alias.

The link is old but the issue is similar.

What does the package do? If it is a weather display, I have an example conky with weather (including graphics) that is lua-free :grin:

wxLua is a gui framework. I hate python, I have always hated python and I hate myself for forcing myself to use it :rofl:

I think the error above is meaningless, I think the example I am trying to run is broken :frowning: It used to run…

This example runs with the same error warning:

No particular usage case then? I thought the ‘wx’ referred to weather!

Not a fan of Python either - I kept trying it, and getting not very far with it. A description sounds like it should be useful, but I’d rather use Bacon :grin: