Wwan setup

I have had a quick search but I can’t seem to see a topic. I am sorry if one already exists, I know I hate the answer the same query over and over!

I have now setup endevour on a second device, this is a thinkpad x230 with a wwan card. Under MX the wwan card was picked up by network manager and I was able to enable/disable it with the GUI. On the surface the gui within XFCE is the same yet that option does not appear to work out of the box so to speak.

An lsusb lists the device as recognized so that does not appear to be an issue.
On following the obvious
https://wiki.archlinux.org/index.php/ThinkPad_mobile_Internet

the modules are installed.

an ip a shows that the device is there. I just dont seem to be able to manage it.

Any ideas?

Do you have modemmanager etc. installed?

https://wiki.archlinux.org/index.php/NetworkManager#Mobile_broadband_support

image

1 Like

Thank you for the quick reply
Yes I can set it up like that. However I am probably missing something really silly here… but I can’t see how to activate the connection. It picks up the operator etc but there is no way in the gui at least to use that connection

It should appear under the nm-applet menu (same as a wifi connection etc.)

(Also check whether the ModemManager service is running.)

1 Like

Thanks for the heads up
Had to install it, then systemctl enable it but cracked it now. Thank you for the support

1 Like