Wrong resolution after reboot

Hello,
after last update I made reboot.
Now my monitor shows 1600x900 instead 3400x1440 ::
And I can’t choose another resolution.
Any help is welcome :frowning:
Thank you in advance!

Here is an Info about my System:

xrandr
Screen 0: minimum 320 x 200, current 1600 x 900, maximum 16384 x 16384
DisplayPort-0 connected 1600x900+0+0 (normal left inverted right x axis y axis) 800mm x 335mm
   1600x900      60.00* 
   1280x1024     60.02  
   1280x800      59.81  
   1152x864      59.97  
   1280x720      60.00    50.00    59.94  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       60.00    59.94  
DisplayPort-1 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 disconnected (normal left inverted right x axis y axis)
HDMI-A-1 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)

lspci -nn | grep -E ‘VGA|Display’
03:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Vega 10 XL/XT [Radeon RX Vega
56/64] [1002:687f] (rev c3)

have you tried this?

https://wiki.archlinux.org/title/xrandr#Adding_undetected_resolutions

1 Like

What desktop are you using?

1 Like

What video/kernel related packages were upgraded?
Not enough info. You can use EnOS log tool to upload more logs.
The least we would need is

inxi -SCGIaz
cat /var/log/Xorg.0.log  # to a pastebin service

If you haven’t rebooted, since the first reboot, post also

cat /var/log/Xorg.0.log.old  # to a pastebin service

to compare with previous logs.

Thank you so much! It works :smiley:

1 Like

Thank you all for your help!

1 Like

Solution (short):

cvt -r 3440 1440
xrandr --newmode "3440x1440R" 319.75 3440 3488 3520 3600 1440 1443 1453 1481 +hsync -vsync
xrandr --addmode DisplayPort-0 3440x1440R
xrandr --output DisplayPort-0 --mode 3440x1440
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.