WPA3 question

So, this is something I’ve wondered about for a while, and it’s not limited to EndeavourOS. It’s the same for KDE Neon as well. And while not in the live environment, it’s also the same for Debian.

I’m GUESSING this issue is a plasma-nm issue, but wanted to see if anyone had any further insite. When running live, I can join my home network without issue (802.11AX using WPA3). Once installed, when I attempt to join it it fails. I can manually go into the “edit network connections” and set up my home SSID/PSK, and immediately upon pressing “ok”, it joins it exactly like it should. Like I said, this happens in ALL the OS’s I currently use as far as plasma-nm failing to join the first time. Void, EndeavourOS, Debian, KDE Neon. After manually setting it up, works perfectly fine from there on out.

Not something I need to figure out how to fix, it’s a minor irritation at worst, and it’s easily worked around. Just wondering if anyone has any insight as to WHY it happens.

I have been checking the Unifi forum about their new implementation of WPA3.
And it seems that depending on the device and OS, it may or may not store the credentials mechanism.

So the problem happens when you have a SSID WPA2, and then you change it to WPA3.
By doing this, the devices which already have the SSID details saved, fails to connect.

Try to forget the network in your KDE, and connect again.

This happens for me even on NEW installations (I just recently got bored so reinstalled most of my machines to move around the OS’s to different laptops).

I’m facing problems with my printer that doesn’t connect to WPA3, even If I use WPA2/WPA3 Transitional with PMF optional, reported the problem the Unifi as per requested by their engineers…

Can you share details about your wifi adapter and AP ?

2 Wifi Adapters affected:

Intel AX200 or Intel AX201.

AP is a ASUS ROG GT-AX11000 w/ Firmware v3.

Has 3 SSID’s configured, 1 is AX only w/ WPA3. 1 is N/AC/AX w/ WPA2 OR WPA3. The third is N only (2.4GHz only) w/ WPA2…just in case.

According to the user’s feedback in Unifi forum, most of them are facing problems to connect to a WPA3 network with that adapter (Intel AX200), they are using Windows by the way.

Found some controversial statements in Unifi forum from users saying that this problem is fixed in latest Windows version 20H2, but I would say that if this problem is happening in Windows too, it could be due to an Intel driver issue… Can’t take any final conclusion about it yet…

Interesting. If I didn’t hate Windows so much I’d throw Windows on one of my laptops to test with. :smiley:
Ultimately though my issue I DO connect, I just have to manually build the connection. It does connect every time (so far, but I’ve had this setup for nearly a year now) AFTER manually creating it, just won’t automagically create it from the networks icon in the system tray.

1 Like

Did you happen to read through any of this?


Edit: Are you using the latest firmware for the WiFi adapters?

I’ve glanced through it. As I mentioned, it DOES join when running Endeavour Live. It’s only AFTER installing it fails, and only fails if I try to do it “automagically” through the system tray icon. Once I open up the network settings and manually type in the SSID/PSK, NM connects and works absolutely fine.

As far as firmware, I’m using the latest that’s been packaged. I tend to not manually update firmware unless ABSOLUTELY necessary for functionality.

I still believe this comes down to something done wrong in plasma-nm and how it interfaces with NetworkManager, as again, if I run with the live ISO, it works exactly as expected, clicking on the wireless, putting in the PSK, and it connects and works. Just the automagic configuration fails with plasma-nm once it’s installed, since I don’t do XFCE, even to test things.

I’m not sure if you can, or if this is the best option, maybe install a new DE like XFCE to test?
Or create a new partition and install EOS with XFCE, later you can remove that partition and fix grub.

Maybe @ricklinux could help you to choose the best option here, what would be easier

Thanks, more tools to work now, I wasn’t aware about WPA3 instructions/troubleshooting in the wiki :slight_smile:

It seems that it’s working in Manjaro, but the user didn’t mention which DE he is using…