World of Warcraft Pre-Patch Issues

Anyone else having problems running this game?

So far I know we need the latest wine-staging (5.19 in my case) to boot the game without crashing.

The issue I have is that within a few short minutes in-game, my whole system freezes and I need to hard-reset my PC.

I know that my amd gpu driver crashes and so far on Linux the video driver cant recover and therefore my system freezes.

I am on kernel 5.8. I tried kernel 5.9 and I tried DX12, DX11 and DX11 Legacy modes but they all have the same issues.

I am wondering if anyone else play’s this game and is also having the same issue with the system locking up.

I play as well, but with nvidia GPU.
I had to reinstall the whole game through lutris and the only change needed after that was selecting wine-staging 5.19 instead of the lutris version and all is working fine now.

I guess that is worth a try, since I have tried every other option that I can think off.

Well, that did not work.

It is either a dxvk/vkd3d issue or a mesa issue seeing as my gpu stalls. Now I need to see if there is a mesa log somewhere that I can sift through.

For those coming here with the same issue from search machines…

The problem was that I had the ‘amdvlk’ packages installed. Because they where installed, those drivers was being used instead of mesa’s radeon vulkan driver.

After removing ‘amdvlk’ the game was using the radeon vulkan drivers and now everything works.

Seems that Linux uses drivers in alphabetical order, and since ‘amd’ comes before ‘radeon’…

3 Likes