Won't boot after updating

Hey, I did a regular pacman -Syu after a short while of not doing it, I ran into some issues with nodejs not allowing the update to happen due to some file conflicts which I fixed, but then after letting the update run fully, my usual terminal emulator (kitty) refused to start. I would get the spinning loader wheel on my desktop after trying to run it, and I wound up using xterm instead to do a reboot. After rebooting, I can get to the GRUB interface but after selecting a kernel it simply loads for a short while, then slowly flashes between a blank screen and a screen with nothing but a cursor. Neither the linux kernel, linux-lts, or either of their initramfs versions will do anything different, all the boots is my old windows installation on another drive. I’m relatively new to Linux, and this is my first major system problem I’ve encountered. I’m on a live boot and I’ve looked through /var/log/pacman.log and can’t find anything of note besides maybe libx11. Any help or advice on how I could fix would be appreciated, can’t find anything anywhere else.

Was running i3 on a Lenovo Legion 5 laptop with a 1660 Ti

I’ve found out through further research that it’s an issue with the upgrade from python 3.9 to python 3.10, specifically to do with optimus-manager. All the advice says to simply run a yay command and rebuild the package, but as I can only access it through a live USB, I can’t figure out how to do so. using chroot and arch-chroot don’t get me very far, as neither can use allow yay or pacman to run the needed update commands. Am I missing some command or thing I need to do to rebuild this package? I can’t figure out or find any other way.

May depend on your DM (lightdm, sddm, etc), but most will let you break out to a TTY if you hit ctrl-alt-Fn and one of the function keys. Such is mentioned on the optimus-manager github page.

optimus-manager 1.4-3 was released in AUR on Dec 14.

Welcome to the forum!

If you can access tty then do that first. If you can’t, how did you chroot?

1 Like

I tried the ctrl-alt-Fn to switch to another TTY already, and in the glimpses I get it does work, but it immediately switches me back to the rebooting one, so I can’t get anything done. I was doing chroot from the the live USB I used to install EndeavourOS, but the link you sent has some extra steps I didn’t do, mainly about mounting. I’ll try them when I’m next at my computer, and see if that works.