WM won’t load after fresh install - Multiple Monitors - DP & HDMI - NVIDIA

Hello all,

So I’ve been doing some googling for about six hours and can’t find any solution that will work. Straight up I probably should be using PopOs while I learn about Linux instead of jumping right into EOS.

I’m guessing the problem has to do with the GPU and it’s display port. As I can launch the live installer no problem with both monitors connected(1080p, HDMI and 1440p DP,) then once I install Gnome I can’t access the WM unless I have the display port monitor unplugged. Being the FNG I am; switched to KDE. While I can now get to the login screen it’s on my HDMI display and the DP display has no signal until after login so it’s slow for it to take back over as primary).

I really want to stick with EOS as it’s nice having access to a great community and the AUR seems nice once I can play with it. Though I’d like to switch back over to the Gnome DE if I could just see the WM(probably do that now and test if I can logging with both monitors counted if I disabled requiring the password on login).

I’ve got a 5700x and a 3070s. If I’ve missed a form post extremely sorry.

Edit: After reinstalling a fresh gnome version and disabling requiring a password on log in. Having both monitors connected still results in both black screens with backlight on after the EOS selection between the main and fallback and UEFI settings splash screen.

Edit 2: I’ve tested it on PopOS and found someone with the same issue on that distro. Reddit User with same issue on PopOS

You shouldn’t do that.

1 Like

Welcome to the forum!

Best way to learn is doing what you’ve been doing. It’ll be tough at first, but it’ll become easier the more you tough it out.

Someone more knowledgeable will likely come around and help you solve this when morning comes in Europe, but until then, let’s cover the basics. Do you have the Nvidia drivers installed? You can check by entering nvidia-installer-check into the terminal. If not, enter sudo pacman -S nvidia-installer-dkms in a terminal, and then do a test run with nvidia-installer-dkms -t. If it returns no errors, run sudo nvidia-installer-dkms and reboot.

I don’t have two monitors, so I don’t know whether it is possible to have both on during boot, but with the Nvidia drivers installed you can open up the Nvidia X server settings application and poke around. At the very least it should offer you the option to set your primary monitor.

Hopefully this helps, but if not, I’m sure someone more knowledgable will come around soon enough.

1 Like

I agree. It’s just a troubleshooting step to save time. Incase I could logging with both monitors connected if I could bypass the WM from not requiring a password. Unless I shouldn’t do that to troubleshoot either?

I’ll start collecting all the forum posts and solutions I’ve tried so that when someone does come across this they’ll know what I’ve tried.

Nvidia installed and updated. Primary display set in the setting to DP monitor. Nada.

Sorry to hear that. There are a few Discovery topics available on Nvidia which may be of use in addition to the forum posts. For example, this article on how to troubleshoot.

Link to all Nvidia entires here.

1 Like

Welcome to the forum @nul :partying_face: :balloon: :tada: :enos_flag: :enos:

Thank you!

I can’t contribute to the solution of the problem, but since yesterday I have a similar problem. I do not want to attach myself to the thread with my problem, but only describe what happened to me.

I also use 2 monitors one via DVI (monitor 1) to HDMI (graphics card) and HDMI (monitor 2) to DP (graphics card). After installing the Nvidia drivers and rebooting, all windows were huge. In the display settings of KDE the correct resolution of 1920x1080 was entered.

Xrandr showed a resolution of over 3600x2000 pixels (don’t remember the exact values). DPI was about 360 and geometry was 160mm x 90mm with a screen diagonal of 32".
Only when I changed in the /etc/X11/xorg.conf.d/20-nvidia.conf the entry

Option "DPI" "96 x 96"

the display was correct. But xrandr still shows wrong values for the screen size.

└──╼ xrandr
Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
1920x1080 60.05 + 59.94 50.00* 23.98 60.00 50.04
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 0mm x 0mm
1920x1080 60.00 + 60.00 59.94 50.00* 23.98 60.00 50.04

I did cut off the smaller resolutions from the output of xrandr here.

After a few hours of searching, reading and trial and error, at least the display settings are correct, so I am a little more relaxed now. But there still seems to be something wrong with it.

EDIT: I forgot the most important thing… welcome to the forum @nul

1 Like

I’ve found a solution that can be applied to EndeavourOS as soon as I test it over there. Currently it’s working on Manjaro Gnome 40.4.0 with Kernal 5.13.19-2 Nvidia Driver 470.63.01.

Current System Specs

  • RTX 3070 Super
  • Ryzen 5800x
  • 32GB Ram
    (The actual cause of the problem)
    Display Port 1440p Monitor
    (Not the cause of the problem)
    HDMI 1080p Monitor

Switching over to Wayland as your Windows System with proprietary drives is apparently more stable now using the Nvidia Drivers for my specific hardware configuration. I followed this guide for Manjaro and I’ve been able to boot into Gnome with-out unplugging/turning off the display port monitor. It even remembers the DP monitor is Primary before logging in.

I’ve powered down the system multiple times just to make sure it wasn’t a fluke and it’s perfect. I’ll update the comment once I’ve tested it on a fresh EOS install.

Edit: It’s a little buggy on EOS Gnome fresh install but it’s working after following the steps in the guide to enable Wayland linked above. One of the bugs is that it’s just show a white box on the login screen where you can enter the password. Then once entered is completely fine. I’ll test out the KDE Desktop with Wayland before marking this as a solution.
Edit2: It’s definitely better on Gnome but it’s at least working without needing to disconnect a monitor every time one reboots. Hopefully this helps others with the current Nvidia Driver!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.