Wine not launching programs properly

hello, I was trying to run an independant windows program with wine outside of steam but the program launched and showed a glitched window rather than what it should show

Hi. Welcome to our community! :enos: :wave:

We may be able to assist if we know where to start.
Few questions:

  • Which program?
  • Which version of wine are you using?
  • Does the program fully launch?
  • Is it usable despite the glitched window?
  • Which DE/WM are you using, and is it on Wayland or X11?
  • Are you new to Linux or new to Arch?

Also, please try running the program from a terminal to see if you can spot any errors.

If you have questions about software that works in Wine. . . go to Winehq.org. They have listed tons of software titles and how they do and don’t work with wine. . . type in the name in the search window of the software and it should spit out how well if at all Wine emulates windows and if the software will even work.

Rich;)

1 Like

Yes, what @rich52 said.

it was a five nights at freddy’s fan game, I was using wine version 9, the program launches but is unusable due to it being just a glitch window, the program is not usable because all I see is glitch, I was using xfce, I am new to arch but I have used linux. and valve proton seems to work

Protondb shows good ratings for most versions of that game. Have you tried adding it to steam as an external game and launching it that way?

I do this with some apps - works sometimes.

thats what I did, I added the fan game to steam and it worked with proton. please note that this is not an official fnaf game i am refering to

Okay. So problem solved? If yes, please mark your response as the solution.

If you have any queries in the future, please provide as much info as possible for assistance. Cheers!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.