Wine missing DLLs

Hi All,

I finally got around to configuring wine on enOS to run the last couple windows apps I need. I installed wine and wine-mono but could not get anything to run, it was complaining about missing dlls (every dll was api-ms-win-*), I did a quick check and sure enough those DLLs were missing from both system32 and syswow64 in the wine prefix.

I quickly tried it on another enOS machine and encountered the same issue, I then tried spinning up a VM with another distro (fedora in this case) and installing wine, wine-mono. The app worked fine here, I checked the folder and sure enough all the dlls that were missing on my enOS install were right there, I copied the system32 and syswow64 folders from the fedora wineprefix over to my host enOS machine and now everything is working great.

So I have it working now but it’s not the most ideal solution, if I want to make another wineprefix I have to copy everything over again, has anyone experienced the same issue or have a solution to it? I tried looking at arch bugreports but couldn’t see anything, it’s very likely i’m overlooking something (does wine on fedora install more stuff than wine on arch?).

Thanks in advance!