Wine installation inconsistencies?

Updating two computers. The newest computer has 8.10.1 of wine installed. The ‘older’ system has 8.8.1 of wine installed. I can’t get it to update to 8.10.1. What can be amiss? When reinstalling on the old computer it comes up with a plethora of installation choices but the deafault is (1) when selected. When I run the default selection the system goes through a list of different packaging where the choser selects ‘1’ for the default values. At some point in time it locks up on one of the choices.
I can’t get 8.10.1 (latest ) version installed updating from 8.8.1. Is this a developmental issue, hardware issue or both. Anyone know what’s happening?

Rich :wink:

1 Like

I’d try updating your mirrors than running Pacman -syu “name of program”

I’ve done this several times. . . . . both mirrors for EndeavourOS and Arch . . . pacman and yay. . . .

You may need to update your keyring, sorry I’m out at the moment and it’s a bit difficult for me to search anything but if this doesn’t work hopefully someone else will be able to point you in the right direction. You can look up how to update the keyring on the wiki I think and I’m 90% sure that there is another post on here about how to do that also.

I went to Winehq and I’m installing source code wine-Wow64-build. . . .This might be the developmental build of the latest version. I’m compiling it now and it’ll probably take a while before I know if this is what it is at this development stage. I 've updated my keyring files for the OS a week ago. This wine package installed on my one computer is newer that the one I’m working on now that’s what I couldn’t figure out with the repositories.

My suspicion that wine is in a developmental state is probably correct. . . My newest computer uses AMD renoir graphics chipset and my older computer uses a Nvidia video card. I think the installation options were dependent upon what graphics you are using i.e. noveau, nvidia or something else thus the different installation options for installing this wine version in this state. Of the couple installation options were some using ‘git’ development repositories also. It took over an hour for my computer to make, compile and install the installation version I chose and in the end it installed itself and works. My windows programs still work when I run wine. So that explains the AUR repository wine dilemma to me I think. I update packages from AUR on both computers and when the newer showed me 'wine 8.10 being installed on my newer machine I was questioning what the deal was with wine because nothing came up for my older machine except different installation options of which I picked the wine-Wow64-build which I had to let my machine compile it before it wold install and run without running into installation errors if I was wrong. Seems I may have been right because everything still works.