Windows not found after reinstall


i installed EndOs a couple of weeks ago and the grub found my windows partition without any hassle “poff” just there by default.

but after an update broke my system and i had to do a re-install now i cant get Windows to show up again.

done what other posts said.

sudo grub-mkconfig -o /boot/grub/grub.cfg

been in my windows partition (got there by switching boot drive in BIOS)
turned off fastboot,hibernation and all manner of things.

Still nothing no windows in my Grub, and i find it infuriating since it worked flawless with my first EndOs install.

So any tips on what it could be

First, are you sure you are using grub? The new installer lets you choose either systemd-boot or grub.

If you are using grub, please share the contents of /boot/grub/grub.cfg and /etc/default/grub

Can you mount your Windows partition r/w from EnOS?

did you try to reinstall grub ?

sudo grub-install

A possible scenario could be that the 2nd time you may have installed on a different type of booting (UEFI against BIOS/Legacy).

I think this is the most likely, I’ve been there in the same way.

1 Like

Hmm there might be a chance i goofed when i installed it as you said. might gone with the default first time and for some odd reason pressed Grub this second time. since i have had this problem with other Distros that came with Grub.
well i guess i just reinstall EndOS again before i get to comfy and see if it fixes it. or just live with going the bios route.

I think @petsam’s scenario is the most likely.

The install happens in either BIOS/Legacy or UEFI based on how you boot the ISO in the first place.

If your Windows is UEFI, make sure you boot the ISO in UEFI mode.

1 Like

only as additional info:
Some Firmware / Bios has two places where you can set CSM legacy on/off !
In case it can be there is an extra setting for USB boot and system boot /drives… so you can set USB boot to have legacy option also system boot is uefi…

1 Like

hmm i will look into it, i know that i have seen usb UEFI when i select it at boot, uncertain if i did it this time.