Windows not detected in EOS grub

I know this problem has been posted multiple times, but i couldnt find solution for my usecase.

I have an SSD with Endeavour OS and Windows 11. During boot, I can choose Linux or Windows from Bios Boot menu.When using EOS grub as first bootable device, i couldnt find Windows Option.

Some details regarding my configuration:

Secure Boot : Disabled

pacman -Qq | grep dracut

dracut 
eos-dracut

Os prober : Enabled

lsblk -l

NAME      MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
nvme0n1   259:0    0 476.9G  0 disk 
nvme0n1p1 259:1    0   117M  0 part /boot/efi
nvme0n1p2 259:2    0 225.8G  0 part /run/media/ma1581/Acer
nvme0n1p3 259:3    0 124.5G  0 part /run/media/ma1581/Personal
nvme0n1p4 259:4    0   499M  0 part /run/media/ma1581/EC8D-B3DD
nvme0n1p5 259:5    0   3.9G  0 part [SWAP]
nvme0n1p6 259:6    0 121.1G  0 part /
nvme0n1p7 259:7    0     1G  0 part 

sudo parted -l

Model: KINGSTON OM8PCP3512F-AA (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                  Flags
 1      17.4kB  123MB  123MB   fat32                                 bios_grub
 2      123MB   243GB  242GB   ntfs            Basi                  msftdata
 3      243GB   376GB  134GB   ntfs                                  msftdata
 4      376GB   377GB  523MB   fat32           Basic data partition  msftdata
 5      377GB   381GB  4194MB  linux-swap(v1)                        swap
 6      381GB   511GB  130GB   ext4
 7      511GB   512GB  1074MB  ntfs            Basi                  hidden, diag

sudo grub-mkconfig -o /boot/grub/grub.cfg

Generating grub configuration file ...
Found background: /usr/share/endeavouros/splash.png
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
done

What does

test -d /sys/firmware/efi && echo UEFI || echo BIOS

show?

test -d /sys/firmware/efi && echo UEFI || echo BIOS

UEFI
1 Like

Have you already removed # from the beginning of this line:

#GRUB_DISABLE_OS_PROBER=false

in /etc/default/grub ?

Also you mentioned that you have your systems on two separate disks but have posted info on only one.

Could you post the whole output of sudo parted -l?

And efibootmgr ?

Yes i have uncommented the OS prober line

Sorry, my bad. Its just single ssd and having it run both windows 11 and endeavour os in the same disk

efibootmgr

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0003,0000,0002,2001,2002,2003
Boot0000* endeavouros   HD(1,GPT,32c139d1-d385-4344-8ed7-d9f5e116565e,0x22,0x3a7de)/\EFI\endeavouros\grubx64.efi
Boot0002* HDD: KINGSTON OM8PCP3512F-AA  PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-26-B7-68-4A-51-8A-B5)/HD(1,GPT,32c139d1-d385-4344-8ed7-d9f5e116565e,0x22,0x3a7de)RC
Boot0003* Windows Boot Manager  HD(4,GPT,8ccd497b-923c-422b-aaa5-e8904914dc8d,0x2bce7000,0xf9800)/\EFI\Microsoft\Boot\bootmgfw.efiRC
Boot2001* EFI USB Device        RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network   RC
1 Like

What is the hardware output? Post the url.

inxi -Faz | eos-sendlog

https://0x0.st/HhTV.txt

You have two FAT32 partitions on your disk.

It appears that this one is the ESP of your EnOS where Grub’s bootloader is installed.

And this one from Windows.

Is that correct?

1 Like

This laptop has intel RST. You may have to have the SATA set to AHCI not Raid or RST disabled?

Yes, thats correct.

1 Like

Yes, i have disabled RST. Currently its set to AHCI

1 Like

Just checking… :wink:

2 Likes

@pebcak will fix you up I’m sure. :wink:

1 Like

Could you set the flags boot,esp on this partition?

You can use a partition manager to do so.

You could also use CLI parted:

sudo parted

After this command you will get an interactive prompt: (parted)

Type print followed by enter to list your partitions.

Identify the number of the fat32 partition: N (4?)

Set boot,esp flag on the ESP. Replace N with the actual number

set N boot on
set N esp on

When done type q followed by enter to quit (parted)

And then run: sudo grub-mkconfig -o /boot/grub/grub.cfg

IT WORKED !!

So i used gparted to set the flags and it worked.
But it somehow stops me from getting into BIOS.

This is a bit of background context:
I initially had a debian+windows 11. Everything was fine until i wanted a taste of EOS(also debian was late with updates). Then after replacing the Debian with EOS(i dont remember how i managed BOOT partition then ), i couldnt see windows 11 in my eos grub screen anymore. I didnt care coz i rarely use it.
I sometimes use bios to manaually change windows as first boot when needed. Then suddenly i couldnt access BIOS(i get stuck in Acer logo when booting to BIOS).Thank god i still had EOS as my first boot.
Then just recently i did a bios reset by unpluging the CMOS cable and pluggin it back in. This time, BIOS worked, after disabling RST EOS booted, after creating new partition for Windows bootbcd i could boot into windows too.
BUT after this solution, i couldnt access BIOS again :cry:
The good part is i have enabled Boot menu, so its ok for me to switch OS using F12, and i know this issue is not part of EOS, but i would like to know where i messed up. So that i can dig up a solution later.

I would like to thank you guys really. I have never exprienced such fast response.
So thanks guys for this @ricklinux @pebcak

1 Like

We shoot and then ask questions :wink: :rofl:

Glad we could help to resolve your issue and welcome to EnOS’ community @mohammedanas1581!

:enos: :handshake:t5:

1 Like

Again you really got your GRUB on! Way to go! :wink:

2 Likes

I don’t really know why you had this issue before and now as well.

I have seen some users having issues accessing BIOS but never have come to a conclusive solution.

The only thing that I, for now, could propose is to run:

systemctl reboot --firmware-setup

and see if the machines reboots into the firmware settings.

If not, I am afraid I have no more ideas at the moment.

Perhaps @ricklinux knows more about this and also maybe other forum members.

i dont think systemctl reboot --firmware-setup command would work, as i had done previously this command, grub option to boot into uefi and check the firmware option from settings of EOS too. All lead to a logo screen Freeze.

Hoping for the better, also could you suggest any other forum that I can consult this on?