Windows dual boot with disk encryption using Calamares

I’ve tried reinstalling this os along side windows but I can’t get Calamares to auto partition my ssd disk.
I’ve used the “Install alongside” option and the tool has correctly resized my windows partition and put inside the new encrypted partition all the root files but it did not seem to install a bootloader.
As a result, my computer only boots back up with windows and grub does not show up (I cannot select anything but windows in my bios boot menu).
I’ve tried setting it up without disk encryption and in the summary there is no entry about the bootloader.
I’ve tried installing it on another disk (erasing the disk) and everything worked as expected.
I can provide more info if needed.
Has anyone else experienced this weird beheavior with the auto partition tool?

Send output of these 2 commands:

sudo fdisk -l
sudo efibootmgr -v

Hello! Thank you for your reply!
Here is the output for the efibootmgr command:

BootCurrent: 000A
Timeout: 2 seconds
BootOrder: 0000,000A,0001,0002,0003,0004,0005,0006,0007,0008,0009,000B
Boot0000* Windows Boot Manager	HD(1,GPT,c1b9e28b-d72b-4b40-8907-ba830d5b561a,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot0001  endeavouros-9246	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0002  ubuntu	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0003  ubuntu	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0004  endeavouros-8148	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0005  endeavouros-6528	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0006  ubuntu	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0007  endeavouros-6823	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0008  endeavouros-8693	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0009  endeavouros-9136	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot000A* UEFI: Verbatim, Partition 1	PciRoot(0x0)/Pci(0x14,0x0)/USB(7,0)/HD(1,MBR,0xb6b4ed2,0x800,0x1daf800)..BO
Boot000B  endeavouros-9686	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)

While here is the output about my disks:

Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WDC WD10EZEX-21W
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 58B44407-7648-9B44-A337-8AD15E34FBAE

Device     Start       End   Sectors  Size Type
/dev/sda1   2048 838862847 838860800  400G Microsoft basic data


Disk /dev/sdb: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: Vi550 S3 SSD    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 6BFC2ECF-95FE-204E-BDAD-096CFD2D15CF

Device         Start        End   Sectors   Size Type
/dev/sdb1       2048     206847    204800   100M EFI System
/dev/sdb2     206848     239615     32768    16M Microsoft reserved
/dev/sdb3     239616  676521210 676281595 322.5G Microsoft basic data
/dev/sdb4  999145472 1000212479   1067008   521M Windows recovery environment
/dev/sdb5  676521211  999145471 322624261 153.8G Linux filesystem

Partition table entries are not in disk order.


Disk /dev/sdc: 14.84 GiB, 15938355200 bytes, 31129600 sectors
Disk model:                 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0b6b4ed2

Device     Boot Start      End  Sectors  Size Id Type
/dev/sdc1  *     2048 31129599 31127552 14.8G  c W95 FAT32 (LBA)


Disk /dev/loop0: 1.6 GiB, 1723146240 bytes, 3365520 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Delete existing Linux partition, and manually create 2 partitions during install:

  • EFI system partition, filesystem FAT32, mount to /boot/efi, size 500 MiB
  • Linux partition, filesystem ext4 (or whatever you want), mount to /, occupy rest of the disk

Are you sure that having the boot loader in the middle of the disk is a good idea? Or is it fine since its at the beginning of the linux os?
If I set up my partition to luks, will my bootloader automatically detect this and ask me the key for the keyring?
Also, if I create a swap partition too, will it be used automatically (for hibernation too)?

UEFI can pick up the EFI partition wherever it is, but I would put it at the end (next to Windows recovery) so if you want to move partitions in the future, you can do that without touching EFI.
If you encrypt your partition via the installer, bootloader should ask you the key.
You may want to use a swapfile instead of partition because a seap partition will need to be encrypted / decrypted seperately.

How would I make endeavour hibernate on it?