Windows 11 - Leaked

NOt required, but makes Bitlocker a lot easier. The advantage of TPM is when encrypting the drive, you can use the TPM instead of a passphrase, so you can have it just boot instead of putting in a passphrase to boot. If it worked (easily) in Linux distro’s I’d probably use TPM. However, while it is POSSIBLE to use it, it’s not an easy “click, click, working” setup, so I don’t.

1 Like

Linux also supports Secure Boot and TPM 2.0. At least some of them.

Edit: Oh Oh… @keybreak I see it’s used to prevent online cheating in games! :laughing:

Mainly it’s used to make your life miserable and less secure in every way :wink:

2 Likes

Along with Windows that’s really terrible then. :rofl:

3 Likes

There are two basic reasons for the limited processor support on Windows 11. First, Windows 11 requires a system to be installed with Trusted Platform Module 2.0 (TPM). … On Windows 10, an enabled TPM wasn’t a necessity. This is changing with Windows 11, as it will require users to have the BIOS options enabled

Edit: Just another move on their part to force people into buying new hardware.

@sothis6881
Are you kidding me? Like i said before.

Okay. Dug a little deeper. My processor is on the list as supporting TMP. It’s an Intel 50th anniversary processor I7-8086K. Intel calls it something else. Go figure! I had to dig a bit and finally found the right setting to enable it. Now it’s listed in device manager and it is TMP 2.0

Edit2:
Intel PTT is Platform Trust Technology
I have it enable now and the device manager shows TMP 2.0 so i will test again Windows 11 support.

Edit3:
Here we go! Now it works!

Knowing is half the battle? :man_shrugging: Not even Microsoft seems to know…I read today that there’s updates expected for the Win 11 compatibility tool

My CPU is not supported… i7 7700, not in the list
Asus H170 pro gaming
UEFI set to other OS in Bios, and not sure about the TMP

image

:rofl: :rofl: :rofl:

“By 2023 will require working webcam always enabled”

5 Likes

Did you look for support for Intel PTT in the Bios?

Edit: Look for PTT Configuration

Afaik, Intel chips older than 8th gen aren’t supported.

I might be wrong though

For this sh*t to work you also need secure boot enabled in UEFI :rofl:

1 Like

Well i was able to enable the TPM on my Intel and it passes the test without enabling secure boot. So i won’t know until i really try and install it. On this Intel board it’s called PTT.

Edit: I also checked it another way because it matters if it’s windows 10 Home or Pro how to check it.

Edit: Also verified here.

It’s nice to see people on linux forum are so eager to run new windows OS and they are troubleshooting what microsoft didn’t fix in the first place. :rofl: :nerd_face:

4 Likes

I was just thinking, this forum is already more useful to me learning Winblows (for work, man’s gotta eat) than M$'s own documentation…

I can’t understand all this excitement. Why are you so concerned about this legacy? We use something that we can also stand behind ideally. Shouldn’t we be happy about that every day? Windows something will never be able to (want to) free itself from the problems that we once left it for. It is a totalitarian system, imposed by a totalitarian corporation on users who do not know how to distinguish. A new wallpaper, no more tiles? Ridiculous … There is no need for any further words … have a nice time!

2 Likes

:100:

3 Likes

Some people just like technology and aren’t that invested in ideology and the struggle of the masses fighting the totalitarian overlords. Windows user talking Linux, Linux user talking Windows - nothing wrong with that.