Windows 10 not shown after dual boot

Used nano:

[boomer@boomer ~]$ sudo su
[sudo] password for boomer:
[root@boomer boomer]# nano /boot/grub/custom.cfg
[root@boomer boomer]# exit
exit

Tried the first one, 1846D85046D8306C.
Same situation. Only to alternatives for Endeavour OS when starting up.
Now going to try with that other serial of numbers.

Now I could see 3rd alternative at the first time, but the timeout is so short that I couldn’t take a picture.
But from the next window I managed to get picture.

I used the second serial 7A82E64082E6008D latest.

Link to picture: https://1drv.ms/u/s!AkXsvqgcSrMCjSH-Z_27sp0dw62c

Are you sure the Windows disk is working?
You can try shutting down, unplugging the Linux disk and boot.

I tried install Endeavour OS with enabled UEFI, but it didn’t work.
I just disabled it and then I managed to install with alternative "KingstonDT101 II 8.20 found under “Legacy Boot Sources”.
Here is one picture from BIOS - Boot Order:

Second picture is from hectical saturday evening.
Trying to install Endeavour OS again. I don’t remeber how many times I tried.
Maybe this (next) picture can clear situation best. Frustration was apparent.

Yes, I can here it that both are running.

I will probably not get the bronze Endeavour OS pin :roll_eyes:

I’m gonna check BIOS again and take a photo of BIOS.

I used SuperGlue - Extra Strong for connecting data cable to that broken connector. Ofcourse not on the pins, but anyway.

Here is photo of situation before booting up again PC.

Okay I will try that as well.

Here is situation with SATA hard disk where Microsoft Windows 10 is installed.

I have not learned about Disk Part but Disk Party :grinning:

Preparations

First, make sure you have a backup of any personal data from both or your disks. They can be a life saver.

Then, make sure you have a Windows boot repair disk (or similar, I’m not really familiar with the Windows terms). This may be needed if the Windows boot system (MBR) fails after boot changes.

Note that the EndeavourOS installer USB stick is also important to have available.

And make sure your system is set to use BIOS legacy boot instead of UEFI boot.

Fixing the boot menu

Next, after the above, make sure both disks are plugged in and boot to EndeavourOS. Then run commands:

sudo grub-mkconfig -o /boot/grub/grub.cfg
sudo grub-install /dev/sda  # overwrites MBR

and reboot.
If you can see both EndeavourOS and Windows menu entries, then it works.
If not, try running the first of the commands above again and reboot.

Thank You , I will now first take care of needed data by copying those to extra hard disks. Let us see how things start to work.
It is nice that I’m getting hughe help

3 Likes

Thank You and everybody else for taking the time to helping me !

My Dual Boot case with MS Windows 10 Pro OS on the own SATA hard driver and Endeavour OS
on own hard drive is now solved.

Continued with backing up files and folders from before installation of both operating systems,
Windows 10 Pro 64-bit and Endeavour.

It was time to look little bit Windows things too.
Converted both SATA hard (2) drives from MBR format to GPT partion format.

With help of MBR2GPT.EXE converted the disks from the Master Boot Record (MBR)
to the GUID Partition Table (GPT) partition style without modifying or
deleting data on the disk. Everything went fine.

Downloaded and installed on Windows latest Rufus with version 3.17 and made
installation media for Endeavour in GPT partition scheme.
Shortened volume label to ‘Endeavour’. Original was longer 'EndeavourOS_202108’.

That is why I found some article that stated that someone was having trouble with
the lengt of “Volume Label”.

Prepared installation of Endeavour OS by disconnecting power and SATA cable from the hard drive (with Windows), for ensuring that GRUB is not installed on the EFI Boot Partition of the Windows 10 hard disk.

I was trying to install Endeavour several times. During the installation I could read from screen
"‘***/EndeavourOS_202108’ did not show up after 30 seconds.”

Tried installation several times. Managed to install Endeavour OS with XFCE (offline), just for testing.
Then installed after in “Online” method. Selected nearly everything to be on the safe side.

Connected the previously disconnected hard disk back for SATA hard drive (with Windows installation).

After PC (desktop) was rebooted , could read 3 alternatives for Endeavour OS from the screen.
Selected first line, ‘Endeavour OS, on Linux’. Windows 10 didn’t show up at the moment.

Checked first, that do I need to download os-prober.
With pacman -Q os-prober showd that “os-prober 1.79-1” is already installed.

Went to next step for editing /etc/default/grub, by changing GRUB_DISABLE_OS_PROBER=true
to GRUB_DISABLE_OS_PROBER=false.

Regenerated grub.cfg, by giving following command:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Resulting:

Generating grub configuration file …
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot: intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/sda1@/efi/Microsoft/Boot/bootmgfw.efi
done

Now Windows can be selected directly from boot menu.

6 Likes

Nice to hear that you got it working now! :+1:
A great learning experience as well! :sweat_smile:

And thanks for writing down the steps you needed to take, that may help some future reader too!

1 Like

I hope that somebody understand what I’m trying to write. Maybe for someone else this case was nothing special. But tried to explain somehow what might be interesting.

4 Likes

Thanks, i got the same problem, you helped me a lot

Thank you sir. It worked after removing # for GRUB_DISABLE_OS_PROBER=false
sudo nano /etc/default/grub
Change
# GRUB_DISABLE_OS_PROBER=false
to

GRUB_DISABLE_OS_PROBER=false

Save the file then;
sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like

Welcome to EnOS’ community @edip !

1 Like

Thank you @pebcak !

1 Like

@edip welcome at the purply way :enos:
maxresdefault
try to not use old threads always better to start a new one… you can link to the old one if needed.