Win 11 bootloader restores precedence over Grub

Well, how much valuable is this experience, when we deal with thousands of different hardware models? Whatever we have not experienced (yet) ourselves means only little, in comparison to so many users from all over the world we are trying to help. :person_shrugging:

:interrobang:

1 Like

Okay but the motherboard in question is all I’m saying is standard same as i would get here. I have many MSI boards of this type. :man_shrugging:

Edit: There are newer UEFI updates for this board that may help.

2 Likes

Don’t you consider yourself lucky? (We all know it. You even never had any issues with KDE, which everyone knows is close to impossible! :joy: ).

1 Like

I blame it on señor Gates :wink:

1 Like

Wow this blew up, thanks to everyone having a go at my problem.
I decided to first what @petsam suggested before taking apart my PC. The first option did nothing at all, replacing the Windows Bootloader got me into a grub rescue shell stating that I had an unknown filesystem.

@ricklinux efibootmgr only shows four entries, I don’t think thats the problem. I dual booted with Windows 10 on the same system before, that shouldn’t be the problem I think.

Flashing the Bios is my next step, should keep it up to date anyway.

1 Like

This might be a good call.

It could remove your EFI boot entry for EnOS though. If that happens you would need to restore it again from the live usb.

1 Like

Check your BIOS settings for something related to disks.

Was that a rescue shell, or normal grub? (what was the prompt?). In normal grub shell, it is possible to find drives/partitions and boot the system.

1 Like

Ya it’s just strange why?

1 Like

Try deleting the existing boot order first by running efibootmgr -O, then run with -o again to set the new boot order.

Optionally this can be combined into one command like so:

efibootmgr -O -o 0002,0000,0004,0001
2 Likes

It was a rescue shell :confused:
What I’ve found about the issue doesn’t seem to apply to overriding the Windows bootloader, so I am a bit stuck on this problem. I am happy to try it again tho. What do you think: Could copying the Windows Bootloader to the Endeavouros disk and overriding it with Grub work? Maybe I could select the Endeavouros disk in the BIOS then? Just guessing.

I’m not sure what you mean by checking the BIOS settings for something related to disks. Both show up in the BIOS, I can select to boot both for this particular boot (Please note I can’t change the first bootpriority to the Endeavouros disk, it doesn’t show up when selecting boot priorities)

What would be something you expected? More or less than four?

Tried that before opening the topic, didn’t work either. Thanks anyway :slight_smile:

Well, would have been a good call… If flashing the BIOS would actually work. I will try it later today with an older BIOS version, but flashing the newest didn’t work. I tried with two different USB drives, M-Flash exited with a message like “No BIOS file found”. I did follow the official MSI guide on upgrading.

And I assume you could change the boot priority for your systems.

Something has apparently happened after your upgrading to Win 11.

The question is “What is that something?” :sweat_smile:

1 Like

Yeah. That’s the question. Let’s go over where I started and what I did from there:

  • I started out with Windows 10 on one drive and Arch Linux on the other drive
  • I upgraded Windows 10 to Windows 11 and did a reset so I had a clean new system (otherwise, Windows would have kept all the files and bloat I wanted to get rid of)
  • I used Win 11 for a few days. Once, I accidentally allowed Grub to try and boot into Arch, which obviously failed, because a new Windows Installation always messes up the Linux install
  • I formatted the Arch Linux Drive and installed Endeavouros on it. You know the rest.

Back when installing Arch, I made an ESP on the same drive, so I had two ESP’s, like I do now. It worked flawlessly, Grub had priority over Windows automatically and I never had to worry about anything.

This is the real problem IMHO, and the UEFI firmware is doing it. That’s why you have to search for:

  • Usage instructions in the motherboard User Manual, on how to change boot order.
  • An UEFI setting that changes order either from a disk drives list, or an NVRAM entries list.
  • Swap disk cables to different connectors

Also,

  • confirm (again) UEFI settings after Win11 installation, as they are usually modified.
  • install EnOS bootloader to the other $ESP. If it also doesn’t work, copy Linux bootloader to the default UEFI path (for the other $ESP), or the WinOS bootloader.
  • Post terminal commands (input and output), so we can try spotting helpful info.

I don’t know what you mean or it doesn’t make any sense.

There are two places you can do that: in UEFI settings pages and in UEFI Quick Boot menu.
Post screenshots for both.

1 Like

check under windows if hibernate is on ,
If for any reason you want to turn off hibernation completely

  • Open command prompt as Administrator
  • Input powercfg /h off and press Enter
1 Like

Edit:

On MSI it usually has two menu options in UEFI for the boot order. At least that is how it is on my MSI boards. The first one is where you can set the fixed disk boot order. The second one is the UEFI boot priority which i set both to the same drives that are supposed to be booting grub from.

2 Likes

YES guys I got it! Ah, thank you so much for your patience and help! Really happy right now :smiling_face:
I had to set the BBS priority. I don’t understand why, I never changed it before, but now it works, still, after multiple restarts. Maybe Windows 11 changed it during install? I honestly never came across that setting before, but switching the BBS priority from the WIndows drive to the Endeavouros drive did it. Amazing :sweat_smile:

1 Like

You figured it out! Congrats!
I hear a sigh of relief from everywhere on the forum :wink: :rofl:

:enos_flag: :wave:t5:

1 Like

Yes this is what happens if you install Windows after.

Would you mind explaining what this is? Acronyms are infinite :person_shrugging: .
A screenshot would be welcome.

I think my UEFI says the same. It show’s here: https://www.msi.com/support/technical_details/MB_Boot_Priority#txt02

Edit: It doesn’t really say but i assume maybe it means Boot Boot Select … menu?

Edit2: Or Boot Boot Setup?