Will it linux? Lets talk about it and see :)

It’s an older think center headed for the dust bin at $job. Always hated the fact I had no access to Endeavour @$job so experiment time!

12 Likes

Sure, i don’t see why it wouldn’t :slight_smile:

What’s on board btw?

2 Likes

My prediction is yes, it will install and work. I could be wrong, of course.

2 Likes

Boots the September release no problem. Everything works so far. I’ll pull an inxi after installation.

9 Likes

All appears to work so far uneventfully :partying_face:

[endeavouros@endeavouros-i3 ~]$ inxi -Fxxxza --no-host
System:
  Kernel: 5.9.1-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux 
  root=UUID=37586e88-629e-4151-8fc1-a0d793eedf8d rw quiet 
  resume=UUID=55906be5-ad11-46e7-ac55-e495b66e9c49 loglevel=3 nowatchdog 
  Desktop: i3 4.18.2 info: i3bar dm: LightDM 1.30.0 Distro: EndeavourOS 
Machine:
  Type: Desktop System: LENOVO product: 10CV0003US v: ThinkCentre M79 
  serial: <filter> 
  Mobo: LENOVO model: Bantry CRB v: SDK0E50510 WIN serial: <filter> UEFI: LENOVO 
  v: FPKT36AUS date: 07/01/2015 
CPU:
  Info: Dual Core model: AMD A4-6300B APU with Radeon HD Graphics bits: 64 type: MCP 
  arch: Piledriver family: 15 (21) model-id: 13 (19) stepping: 1 microcode: 6001119 
  L2 cache: 1024 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 14777 
  Speed: 1796 MHz min/max: 1800/3700 MHz boost: enabled Core speeds (MHz): 1: 1847 
  2: 1962 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Richland [Radeon HD 8370D] vendor: Lenovo driver: radeon v: kernel 
  bus ID: 00:01.0 chip ID: 1002:9998 
  Display: x11 server: X.org 1.20.9 compositor: xcompmgr driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: <xdpyinfo missing> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: AMD Trinity HDMI Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:01.1 chip ID: 1002:9902 
  Device-2: AMD FCH Azalia vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 chip ID: 1022:780d 
  Sound Server: ALSA v: k5.9.1-arch1-1 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo 
  driver: r8169 v: kernel modules: r8168 port: e300 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0f0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 5.62 GiB (1.2%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm 
  serial: <filter> rev: KC66 scheme: GPT 
Partition:
  ID-1: / raw size: 62.99 GiB size: 61.75 GiB (98.03%) used: 5.43 GiB (8.8%) fs: ext4 
  dev: /dev/sda2 
  ID-2: /home raw size: 387.14 GiB size: 380.07 GiB (98.17%) used: 196.0 MiB (0.1%) 
  fs: ext4 dev: /dev/sda3 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 15.14 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda4 
Sensors:
  System Temperatures: cpu: 0.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 147 Uptime: 12m Memory: 3.57 GiB used: 916.9 MiB (25.1%) Init: systemd 
  v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 749 lib: 196 Shell: Bash v: 5.0.18 
  running in: xfce4-terminal inxi: 3.1.08 
[endeavouros@endeavouros-i3 ~]$ 

6 Likes

same here all seems fine so far.

alienprober@TheMotrhership ~> inxi -Fxxxza --no-host
System:
  Kernel: 5.9.1-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux 
  root=UUID=128d1d7c-1028-4416-b91d-882b6c7c7d2b rw rootflags=subvol=@ 
  quiet loglevel=3 nowatchdog 
  Desktop: KDE Plasma 5.20.1 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: EndeavourOS 
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx 
  serial: <filter> UEFI: American Megatrends v: 3103 date: 06/17/2020 
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard K360 
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes 
  status: Discharging 
CPU:
  Info: Quad Core model: AMD Ryzen 3 3200G with Radeon Vega Graphics 
  bits: 64 type: MCP arch: Zen+ family: 17 (23) model-id: 18 (24) 
  stepping: 1 microcode: 8108109 L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 28762 
  Speed: 1321 MHz min/max: 1400/3600 MHz boost: enabled Core speeds (MHz): 
  1: 1246 2: 2438 3: 1801 4: 1234 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, 
  STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: eVga.com. 
  driver: nvidia v: 455.28 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:2187 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia 
  unloaded: fbdev,modesetting,vesa alternate: nouveau,nv display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 2560x1080 s-dpi: 97 s-size: 670x283mm (26.4x11.1") 
  s-diag: 727mm (28.6") 
  Monitor-1: HDMI-0 res: 2560x1080 hz: 60 dpi: 97 
  size: 673x284mm (26.5x11.2") diag: 730mm (28.8") 
  OpenGL: renderer: GeForce GTX 1650 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 455.28 
  direct render: Yes 
Audio:
  Device-1: NVIDIA TU116 High Definition Audio vendor: eVga.com. 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:1aeb 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 0a:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.9.1-arch1-1 
Network:
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb 
  v: kernel port: d000 bus ID: 04:00.0 chip ID: 8086:1539 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 16.38 TiB used: 7.63 TiB (46.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 model: Viper M.2 VPN100 size: 238.47 GiB block size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> 
  rev: ECFM22.6 scheme: GPT 
  ID-2: /dev/sda vendor: Western Digital model: WD10EARS-00Y5B1 
  size: 931.51 GiB block size: physical: 512 B logical: 512 B 
  speed: 3.0 Gb/s serial: <filter> rev: 0A80 scheme: GPT 
  ID-3: /dev/sdb vendor: Seagate model: ST3000DM001-1E6166 size: 2.73 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: SC48 scheme: GPT 
  ID-4: /dev/sdc type: USB vendor: Seagate model: Expansion Desk 
  size: 7.28 TiB block size: physical: 4096 B logical: 512 B 
  serial: <filter> rev: 9401 scheme: GPT 
  ID-5: /dev/sdd type: USB vendor: Seagate model: Expansion size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B serial: <filter> rev: 9300 
  scheme: GPT 
  ID-6: /dev/sde type: USB vendor: MediaMax model: WL3000GSA6454 
  size: 3.41 TiB block size: physical: 4096 B logical: 512 B 
  rotation: 5400 rpm serial: <filter> scheme: GPT 
Partition:
  ID-1: / raw size: 237.99 GiB size: 237.99 GiB (100.00%) 
  used: 46.44 GiB (19.5%) fs: btrfs dev: /dev/nvme0n1p2 
  ID-2: /home raw size: 237.99 GiB size: 237.99 GiB (100.00%) 
  used: 46.44 GiB (19.5%) fs: btrfs dev: /dev/nvme0n1p2 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 51.9 C mobo: N/A gpu: nvidia temp: 42 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 341 Uptime: 18h 34m Memory: 15.62 GiB used: 4.07 GiB (26.0%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1381 pacman: 1331 
  lib: 356 flatpak: 43 snap: 7 Shell: fish v: 3.1.2 default: Bash v: 5.0.18 
  running in: konsole inxi: 3.1.08 
alienprober@TheMotrhership ~>

So it is an old dual core AMD with integrated graphics and 4 gib ram. Works fine in i3

6 Likes

Not that bad :slight_smile:
You can run KDE easily in there :yum:

3 Likes

BTW I use i3wm :laughing:
Seriously though i have been using i3 on the main rig for a few weeks now. With this I can play around with .config files and then move them over to the main machine.

6 Likes

but…but…i3 is soooo bloated…One would want to check something like dwm :slight_smile:
btw :grin:

3 Likes

Check your journalctl -p 3 -xb just to make sure :wink:

4 Likes

Maybe he’ll find Deepin hiding in there :rofl:

4 Likes

it’s actually not that bad for a 5 year old BIOS:

ct 21 10:18:37 endeavouros-i3 kernel: AMD-Vi: [Firmware Bug]: : IOAPIC[0] not in IVRS table
Oct 21 10:18:37 endeavouros-i3 kernel: AMD-Vi: [Firmware Bug]: : No southbridge IOAPIC found
Oct 21 10:18:37 endeavouros-i3 kernel: AMD-Vi: Disabling interrupt remapping
Oct 21 10:18:37 endeavouros-i3 kernel: ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - \_PR_.C000 (20200717/dspkginit-438)
Oct 21 10:18:39 endeavouros-i3 kernel: EDAC amd64: Error: F1 not found: device 0x1601 (broken BIOS?)
Oct 21 10:18:39 endeavouros-i3 kernel: EDAC amd64: Error: F1 not found: device 0x1601 (broken BIOS?)
Oct 21 10:18:42 endeavouros-i3 kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.ALIB], AE_NOT_FOUND (20200717/psargs-330)
Oct 21 10:18:42 endeavouros-i3 kernel: ACPI Error: Aborting method \_SB.PCI0.VGA.ATC0 due to previous error (AE_NOT_FOUND) (20200717/psparse-529)
Oct 21 10:18:42 endeavouros-i3 kernel: ACPI Error: Aborting method \_SB.PCI0.VGA.ATCS due to previous error (AE_NOT_FOUND) (20200717/psparse-529)

PS I have been using that command since you got me started on Arch. I still have some of your tutorials/posts from MJ forums printed out :laughing:

5 Likes

Yeah i remember when starting out, we’ve learned this command simultaneously with @antechdesigns for good on Deepin’s bug tracker…that’s most useful command out there :upside_down_face:

Oct 21 10:18:39 endeavouros-i3 kernel: EDAC amd64: Error: F1 not found: device 0x1601 (broken BIOS?)
Oct 21 10:18:37 endeavouros-i3 kernel: AMD-Vi: [Firmware Bug]: : No southbridge IOAPIC found

Those couldn’t be good, try to fix them with the power of internet! :slight_smile:

3 Likes

LTS is a little better:

endeavouros@endeavouros-i3 ~]$ journalctl -p 3 -xb
-- Logs begin at Wed 2020-10-21 09:30:00 EDT, end at Wed 2020-10-21 11:00:25 EDT. --
Oct 21 10:59:53 endeavouros-i3 kernel: AMD-Vi: [Firmware Bug]: : IOAPIC[0] not in IVRS table
Oct 21 10:59:53 endeavouros-i3 kernel: AMD-Vi: [Firmware Bug]: : No southbridge IOAPIC found
Oct 21 10:59:53 endeavouros-i3 kernel: AMD-Vi: Disabling interrupt remapping
Oct 21 10:59:53 endeavouros-i3 kernel: ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - \_PR_.C000 (20190816/dspkginit-438)
Oct 21 10:59:59 endeavouros-i3 kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.ALIB], AE_NOT_FOUND (20190816/psargs-330)
Oct 21 10:59:59 endeavouros-i3 kernel: ACPI Error: Aborting method \_SB.PCI0.VGA.ATC0 due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Oct 21 10:59:59 endeavouros-i3 kernel: ACPI Error: Aborting method \_SB.PCI0.VGA.ATCS due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
[endeavouros@endeavouros-i3 ~]$ 
4 Likes
3 Likes

Yes I have to add this: ivrs_ioapic[7]=00:14.0 ivrs_ioapic[8]=00:00.1 to my grub on a sabertooth motherboard.

Obviously @Elloquin numbers maybe different [7] [8]

3 Likes

@Elloquin see if it handle real bloat… try KDE :crazy_face: :fire: :wink:

In coming!!! 55555555 :rofl:

1 Like

@Shjim you mis-typed Gnome :wink:

3 Likes

555555555555