WiFi works only after booting Windows10 then reboot to EndOS

I found a work around for this but I am curious on why this is happening.

I have 2 hard drives so I dual boot into Windows or EndeavourOS from grub menu.

If I turn PC on and boot into EndOS, Wifi is not found and does not work.

If I turn PC on and boot into Windows 1st, WIFI works, then I reboot and boot into EndOS then WIFI works no problem.

Can anybody explain the reasoning behind all this?


1 Like

The Windows device driver is messing with the device. It’s a pretty common thing for hardware to work properly only with Windows as companies write drivers only for that platform.

Essentially, you can try altering the Windows device driver settings, or complaining to the manufacturer, or buying a new adapter that has proper Linux support.

Or you can try perhaps some Open source firmware for your router, for example:

If i understood correctly what @jonathon said, or you meant wi-fi reciever?

P.S. Obviously at your own risk and all that :wink:

Also listing your inxi -Fxxxz would help, at least we can see your device / driver :upside_down_face:

I’m not sure others have fully understood the query perhaps? I’ve had this too in the past, - your machine is probably using Fastboot, which effectively locks the devices into standby mode. So if you boot into another OS, the wifi fails as it’s still sitting in hibernate for Windows. Shutdown for windows no longer means shutdown, - it’s effectively a hybrid of hibernate.

I had to disable fastboot in the BIOS so that when Windows was shut down, it actually released devices and did a proper “cold” shutdown. A reboot is effectively a proper shutdown and restart in the classical sense.


For reference: https://wiki.archlinux.org/title/Dual_boot_with_Windows#Fast_Startup_and_hibernation


Aye, my first thought when I read the title. Definitely check your BIOS and kill that abomination.

1 Like

Keep in mind there is fast boot in the Bios and also the Fast Start Up feature on Windows 10 which uses hiber file. This is more likely the problem then fast boot in the Bios.


Oh dear god, there’s more inside that poor excuse for an operating system?

Kill all of it…

So it looked like fastboot was disabled on my bios but the windows 10 feature was not. Once I disabled the windows 10 “fast startup” , everything was solved.

This was the solution if anyone else comes across this issue and fastboot on bios does not fix it.

Thank you @ricklinux , you were spot on.

Fix: https://www.windowscentral.com/how-disable-windows-10-fast-startup


You marked your own post as the solution rather than the post that actually gave you the answer?

I mean, really. :unamused:

Well I posted the solution guide I found so others could click it. I am not sure of the rules I just figured that would be best for future folks doing searches. This is my first time ever clicking the solution button so forgive me for making you upset.

It’s just basic politeness to give credit or thanks to the person (or people) who helped you.

I’m not upset. I’m disappointed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.