Wifi stops working after a while

So I have always had problems with wifi on linux on my laptop. I went from linux mint to ubuntu to now endeavourOS and all of them had problems. It started with there just not being drivers for my wifi card (This is solved now) then the problem I have now started.

My problem is that after about an hour of use the wifi on my laptop will just stop working it will not connect to any network and it repeatedly tries to connect and says connection failed or something (Will update with what it actually says when it happens again).

The only way I have found to fix this Is just restarting my laptop. I haven’t found much information on issues like this but I tried restarting my drivers with sudo systemctl restart NetworkManager which doesn’t work. Updating/reinstalling drivers didn’t help.

My laptop is a HP Probook 445 G9 14 inch

What is the WiFi chip

inxi -Na

Realtek RTL8852BE PCIe 802.11ax Wireless Network

I would have preferred to see the output to see other info. As far as i know it should be running on a kernel module:

Edit: You could try the rtw89-dkms-git package.

Here is the entire output

Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard ProBook 445 G9/455 G9 driver: r8169 v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  Device-2: Realtek RTL8852BE PCIe 802.11ax Wireless Network
    vendor: Hewlett-Packard driver: rtw89_8852be v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:b852
    class-ID: 0280

 Device-2: Realtek RTL8852BE PCIe 802.11ax Wireless Network
    vendor: Hewlett-Packard driver: rtw89_8852be v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:b852
    class-ID: 0280

Is this after installing the rtw89-dkms-git package? Or before trying it?

I am installing it now!

It say’s that it should build for this chip so well see if it works or not?

after installing rtw89-dkms-git it now says “Connection failed: Activation of network connection failed” and after uninstalling the package it still doesn’t work

Did you reboot after uninstalling the package?

Yes

How did you uninstall it? Hopefully only using yay -R rtw89-dkms-git ?

yes that is how I uninstalled it

Strange why it wouldn’t just revert. :person_shrugging:

tried reinstalling rtw89-dkms-git but still no luck. All the networks show up but it cant connect.

dual boot ? just asking

What does this show on a fresh boot.

dmesg | grep rtw

Edit: Maybe you need to remove the module and reload it? Not sure what it’s named. You can check what modules are loading with lsmod

Maybe?

sudo rmmod rtw89_8852be
sudo modprobe rtw89_8852be

Edit: You could also check that nothing is blacklisting it in a file in /etc/modprobe.d/ just in case the package you installed did that.

I think the rtl8852be is a fairly new version of the realtek chip for 802.11ax standard. Not sure what the issue is with it giving this trouble.

Edit: Maybe this helps or gives some additional info?

https://bbs.archlinux.org/viewtopic.php?id=293775

As far as i know native support for the Realtek 8852BE chipset was supported by kernel 6.1 at the earliest, so it should work out of the box with current kernels.

yes