Wifi not working after a hard crash while updating

Hello!

I was updating normally with YAY and just in the last stages of it where it crashed, I couldn’t use the magic sysrq key as this is happening often that my caps locks starts blinking and REISUB doesn’t works. I am planning to format it, but as I am doing some project I prefer to do it later. The issue is that it happened more than one 3 times now.

When I turn my laptop on again, I can see that the wifi doesn’t scan any connections, even rebooting doesn’t works.

I tried looking other post related to this and they solved it with a shut down, letting it rest for a while and then it is suppose to work. I will update this post later if that’s the case as for now I am letting it rest.

What should I do to scan if I have any other issues aside from the Wi-Fi?

Thanks. I am using gnome as for more information you can ask me.

inxi -Na:

Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8168 v: 8.053.00-NAPI modules: r8169 pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0
chip-ID: 10ec:8168 class-ID: 0200
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:2723 class-ID: 0280

I tried the following commands:

sudo systemctl restart NetworkManager

What I would do in a similar situation would be back up my home folder (things I don’t want to risk losing) and try update with first pacman -Syu and then try yay after to rule out what is causing this

I already tried and updated everything with sudo pacman -Syu and yay through wired connection or ethernet. (PS. Had to also do sudo rm /var/lib/pacman/db.lck at first as I was getting an error related to it).

But it still not working, the wifi only keeps scanning but can’t find any network, when I am in windows (dual boot) it works fine:

image

Also for some reason now my desktop background is all black:

I solved the issue. For those who have the same problem. This was the solution for my case, you should pay attention on boot for failed services/components or check the journalctl.

TL;DR: Reinstall pcsclite with sudo pacman -S pcsclite. You might get an error with conflicting files, for that you have to use --overwrite (But you can also resolve the conflicts yourself if you want to avoid using overwrite).

While rebooting I found a Failed in one component:

Failed to start WPA supplicant.

With journalctl -b | grep wpa to analize the issue I got:

may 09 10:25:20 mylaptop wpa_supplicant[963]: /usr/bin/wpa_supplicant: error while loading shared libraries: /usr/lib/libpcsclite.so.1: file too short

The error message provided indicates an issue with the libpcsclite.so.1 library, which is part of the pcsclite package. The error message “file too short” suggests that the library file is corrupted or incomplete. So I just reinstalled it and now the wifi works correctly.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.