WiFi driver form AUR during installation - is it possible?


An IdeaPad notebook is planned to be delivered on the next weekend, and I’m going to install EOS on it. I have found WiFii moudle in use needs Realtek 8852BE driver still not included into the kernel. The driver AUR home is here: https://aur.archlinux.org/packages/rtw89-dkms-git

Is it possible to “insert” the driver during installation? I can build a package from the workstation running Manjaro.

(planned installation: single boot; LUKS for data, not for boot; ext4)

You could try installing the package in the live session and then try inserting the module “on the go” with modprobe command line. Might work.
However I’ve never tried this myself so I don’t have a first hand experience.

Something like:

sudo modprobe -v rtw_8852ae


1 Like

I don’t think this will work as it will only load on the live session and once install is finished and reboot it will be lost. :thinking: Needs rtl8852be-dkms-git

Unless I’m wrong. :man_shrugging:

Isn’t that what OP wants? To get the WiFi going on the Live session?
I might have misunderstood :blush:

After reboot I will get working system just without networking. Then I can use pkg.tar.xz package to manually install the driver from flash stick. Or - are there intermediate reboots during installation? Or - am I completely wrong somewhere?


If you want to do an online install, you could also usb-tether your mobile phone and get Internet connection in the Live session.


Have never used usb-tether before. Just tried with my workstation running KDE - yes, it works. Great idea! Will try it at first on notebook arriving and will notify here.

1 Like

Might want to mark @pebcak msg as the solution - certainly sounds like the best bet!

1 Like

Yes, I’m going to mark just after real trick applying.

I’ve got the same problem
HP probook with Realtek 8852BE
I hope that the driver will be included in the Kernel 6.2
in the meantime I’ve bought this:
https://www.tp-link.com/us/home-networking/wifi-router/tl-wr802n/ to get the wifi connection

1 Like

This should be supported by 6.1 kernel and above but not sure. If not there is rtl8852-be-dkms-git but i would try the rtw89-dkms-git which has newer realtek drivers and this one is listed.

Maybe i misunderstood also? I’ve never had to do this with any of my WiFi adapters. They all work with no issues. Both realtek and broadcom.

This concrete WiFi Realtek module is not supported by the kernel for now (at least by 6.0.12 used in EOS installer).

I think it’s been explained that if you need WiFi you have to use tethering in order to install or Ethernet if that’s an option. The installed kernel will be 6.1.6 so it should work on the installed system but I can’t confirm. If not then you’ll have to install one of the packages from the AUR to get it working. My understanding is support is supposed to be in 6.1 kernel and above.

Do you already have an installed system and it doesn’t work on the current kernel?

As I have noted at the beginning, the notebook is on the delivering at the moment.

Yes, I have said about it earlier.

I read that earlier and forgot but that doesn’t change anything. :thinking:

Unfortunately notebook retailer mistake has resulted in changing notebook model (and the new one hasn’t got any hardware incompatible with EOS installer), so I can not verify @pebcak USB-tether trick, so marking it as a solution in advance. Thanks.


Good luck with your new computer and EnOS’ installation!


1 Like