Wifi disconnection while updating/installing packages in KDE Plasma

Hi, newbie here! I recently freshly installed EndeavourOS with KDE Plasma. I’ve been experiencing wifi dropouts or even disconnections while using pacman -Syyu and updating mirrors, either by using Reflector or the eos ranking mirror command. My internet connection seems to be fine as there is no connection problem in my other devices.

After the first one, I tried another fresh install, then update the system/mirrors in the live session (xfce) and there was no problem, everything went normal.

This is my inxi -na and iwconfig output:

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: N/A modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter
    vendor: Lite-On driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 03:00.0 chip-ID: 168c:0034 class-ID: 0280
  IF: wlan0 state: down mac: 48:d2:24:e6:84:f5

wlan0     IEEE 802.11  ESSID:"IZZI-9114"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: A4:98:13:5B:61:48   
          Bit Rate=86.7 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=69/70  Signal level=-41 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:61   Missed beacon:0

Interestingly, the wlan0 state from the inxi output goes from up to down (matching the connection dropouts).
This is what I’ve already tried but with no success:

  • the modprob option nohwcrypt=1 from arch wiki
  • using LTS kernel
  • disabling IPv6 as mentioned in solutions from a few years ago or so. Apparently a problem with kde wallet.

Thanks in advance!

Have you tried disabling this? Not an expert just having a guess

How do you know? Did you also try?


Possibly also add