WiFi Device not Ready

When I start my system, I can’t use WiFi. It just says “Device not Ready”, and it stays like that until I turn off the computer. But, sometimes this doesn’t happen and the computer starts up normally. It’s really weird because it doesn’t happen 100% of the time, so I don’t know what to do. Can anyone help me?

Can you post the link from this command for your hardware.

inxi -Faz | eos-sendlog

Is it this link? https://clbin.com/FrVEE

Yes that is correct. Can you also post the output of this?

lsmod | grep rtw

Edit: Also wanted to ask if you are dual booting with Windows?

Yes, I am dualbooting. I use Windows 10.

Also, this was the output:

rtw88_8723de           16384  0
rtw88_8723d            61440  1 rtw88_8723de
rtw88_pci              36864  1 rtw88_8723de
rtw88_core            253952  2 rtw88_8723d,rtw88_pci
mac80211             1216512  2 rtw88_pci,rtw88_core
cfg80211             1064960  2 rtw88_core,mac80211

In Windows you should try turning off fast start up feature that is a power management setting. See if it works properly after restarting.

I also wanted to ask if you installed any packages to make the WiFi work? Or did it work after the install?


The first time I started EndeavourOS after install, it worked fine. A few days later, I got the problem and after rebooting it was fixed. And it has been happening randomly ever since. Also, I didn’t install any extra packages for WiFi.

Try the above package that @joekamprad suggested

yay -S rtw88-dkms-git

After a few restarts, the “Device not Ready” error happened again, even with the package you mention. What should I do now? Also, something I noticed is that Ethernet works fine, it’s just Wi-Fi that doesn’t.

You may need to blacklist some modules that may be interfering.



How do I know what I have to blacklist?

I thought it explained it above on the github page for the module you are using.


Blacklisting (needed if you want to use these modules)

Some distros provide RTL8723DE drivers. To use this driver, that one MUST be blacklisted. How to do that is left as an exercise as learning that will be very beneficial.

If your system has ANY conflicting drivers installed, you must blacklist them as well. For kernels 5.6 and newer, this will include drivers such as rtw88_xxxx. Here is a useful link on how to blacklist a module

Once you have reached this point, then reboot. Use the command lsmod | grep rtw and check if there are any conflicting drivers. The correct ones are:

  • rtw_8723de rtw_8723d rtw_8822be rtw_8822b rtw_8822ce rtw_8822c rtw_core and rtw_pci

If you have other modules installed, see if you blacklisted them correctly.

How to disable/enable a Kernel module

sudo modprobe -r rtw_8723de #This unloads the module sudo modprobe rtw_8723de #This loads the module