WiFi connects but there's no internet

Hi all! I have a weird issue which started earlier this week. I’ve been using endeavour os xfce flavour for just over a month by far everything was fine and dandy but now I don’t have internet with wi-fi being successfuly connected. Tried two different networks. Same computer has no issues while I boot Windows 10 or Manjaro openbox. This happened on Thursday and is still here today :slight_smile: didn’t run endeavour yesterday. Should I post some logs or outputs? Thanks in advance.

Hello @BerZerg
Are you able to ping out to any sites?

ping -c5 www.google.com

Also what is the output for

lspci -nnk | grep -iA2 net

Thanks for such quick response. Much appreciated.

[berzerg@ivanlutsenko-vostro5481 ~]$ ping -c5 www.google.com
PING www.google.com (173.194.73.103) 56(84) bytes of data.
64 bytes from lq-in-f103.1e100.net (173.194.73.103): icmp_seq=1 ttl=45 time=26.4 ms
64 bytes from lq-in-f103.1e100.net (173.194.73.103): icmp_seq=2 ttl=45 time=30.5 ms
64 bytes from lq-in-f103.1e100.net (173.194.73.103): icmp_seq=3 ttl=45 time=45.3 ms
64 bytes from lq-in-f103.1e100.net (173.194.73.103): icmp_seq=4 ttl=45 time=45.8 ms
64 bytes from lq-in-f103.1e100.net (173.194.73.103): icmp_seq=5 ttl=45 time=44.2 ms

--- www.google.com ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4007ms
rtt min/avg/max/mdev = 26.435/38.422/45.799/8.256 ms
[berzerg@ivanlutsenko-vostro5481 ~]$ ping -c5 www.ya.ru
PING ya.ru (87.250.250.242) 56(84) bytes of data.
64 bytes from ya.ru (87.250.250.242): icmp_seq=1 ttl=54 time=8.48 ms
64 bytes from ya.ru (87.250.250.242): icmp_seq=2 ttl=54 time=7.02 ms
64 bytes from ya.ru (87.250.250.242): icmp_seq=3 ttl=54 time=11.9 ms
64 bytes from ya.ru (87.250.250.242): icmp_seq=4 ttl=54 time=8.89 ms
64 bytes from ya.ru (87.250.250.242): icmp_seq=5 ttl=54 time=12.2 ms

--- ya.ru ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4006ms
rtt min/avg/max/mdev = 7.023/9.716/12.245/2.038 ms
[berzerg@ivanlutsenko-vostro5481 ~]$ lspci -nnk | grep -iA2 net
00:14.3 Network controller [0280]: Intel Corporation Cannon Point-LP CNVi [Wireless-AC] [8086:9df0] (rev 30)
	DeviceName: Onboard - Ethernet
	Subsystem: Intel Corporation Cannon Point-LP CNVi [Wireless-AC] [8086:42a4]
	Kernel driver in use: iwlwifi
--
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
	Subsystem: Dell RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1028:08a7]
	Kernel driver in use: r8168
	Kernel modules: r8169, r8168
[berzerg@ivanlutsenko-vostro5481 ~]$ 

Ping is perfect :smile: to add to absurdity I’m enclosing screenshot with several “no internet” errors and perfect pings. That’s funny. Too bad can’t work with it.

So you actually have an internet connection. Are you unable to open a browser and go to any site? I see you have octopi open and it doesn’t fetch the updates? I also see the update notifier and welcome screen not allowing updates.

Have you tried in the terminal to update as it might be a mirror issue.

sudo pacman -Syyuu

1 Like

Unfortunately not. I tried Udemy, gmail, google.com and some sites. Firstly I was given some “failed certificates” errors not it’s “no connection”. I use Opera, but as octopi and welcome app both have connections errors I guess it’s not the browser’s problem.

You tried the update command from the terminal? It has to be a mirror key issue as you are able to ping website so you are able to get out to website.

Edit: What happens when you run sudo pacman -Syyuu

[berzerg@ivanlutsenko-vostro5481 ~]$ sudo pacman -Syyuu
[sudo] пароль для berzerg: 
:: Обновление баз данных пакетов...
 core                            134,0 KiB  1835 KiB/s 00:00 [--------------------------------] 100%
 extra                          1713,7 KiB   666 KiB/s 00:03 [--------------------------------] 100%
 community                         4,9 MiB  1748 KiB/s 00:03 [--------------------------------] 100%
 multilib                        159,2 KiB  2,22 MiB/s 00:00 [--------------------------------] 100%
ошибка: не удалось получить файл 'endeavouros.db' из mirror.alpix.eu : error setting certificate verify locations:
  CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
ошибка: не удалось получить файл 'endeavouros.db' из ftp.acc.umu.se : error setting certificate verify locations:
  CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
ошибка: не удалось получить файл 'endeavouros.db' из mirror.linux.pizza : error setting certificate verify locations:
  CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
ошибка: не удалось получить файл 'endeavouros.db' из github.com : error setting certificate verify locations:
  CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
ошибка: не удалось получить файл 'endeavouros.db' из raw.githubusercontent.com : error setting certificate verify locations:
  CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
ошибка: не удалось обновить endeavouros (ошибка в библиотеке загрузки)
ошибка: failed to synchronize all databases
[berzerg@ivanlutsenko-vostro5481 ~]$ 

Russian language pieces: 
error: couldn't get the file ... from...

error: couldn't update endeavouros (error in download library)

@BerZerg

Welcome! :smile:

A tip: to show command output in English, you can simply add a “prefix” LANG=C to a command, for example:

LANG=C sudo pacman -Syyuu

EDIT: seems that certificate files are not correct. This is what I have here:

$ ls -la /etc/ssl/certs/ca-certificates.crt 
lrwxrwxrwx 1 root root 49 2020-01-22 11:12 /etc/ssl/certs/ca-certificates.crt -> ../../ca-certificates/extracted/tls-ca-bundle.pem

Maybe your install had issues? If that’s the case, I’d suggest re-installing, perhaps into a VM (e.g. VirtualBox) to rule out some potential hardware issues.

1 Like

@manuel
Quite a handy command thanks, will try to remember it. Not sure if I will be able to. :slight_smile:

Is there a way to reinstall the certificates separately? I don’t feel like installing needed soft once again unless it’s the only way. By the way current install worked for a month. Could this certificate problem occur right out of the blue?

Let zim remember it for you..
I am 69 years old and I needed to put some zim in my life. :rofl:

Pudge

1 Like

@BerZerg
What does this command show.

sudo pacman -Qkk ca-certificates-{cacert,mozilla,utils}
1 Like

@BerZerg
Maybe you can fix it by reinstalling certificates.

sudo pacman -S ca-certificates-utils

If you have problems fetching the certificate package with pacman, you can download and install it as follows:

# download:
wget -O ca-certificates-utils-20181109-3-any.pkg.tar.zst https://www.archlinux.org/packages/core/any/ca-certificates-utils/download

# install:
sudo pacman -U ca-certificates-utils-20181109-3-any.pkg.tar.zst
1 Like

@ricklinux @manuel

Thanks guys! Your messages helped me understand where was the mistake. It was mine. I deleted ca-certificates-mozilla as I thought that it’s only used by Mozilla.
sudo pacman -Qkk ca-certificates-{cacert,mozilla,utils} didn’t work so I downloaded packages ca-certificates and ca-certificates-mozilla in Manjaro and installed them in Octopi locally.

Some useful experience was earned :face_with_hand_over_mouth:

2 Likes