Wifi connection issues

Earlier today I was able to use wifi on my computer just fine, but now I can’t. I’ve tried using the ethernet cable I’ve connected to a wifi extender, but that doesn’t work. I’ve had limited success by using a wifi adapter - I’m able to connect to the internet but the connection is spotty and sometimes I’m unable to even browse the web.

What can I do to find the source of this issue?

Hi. Sorry you are having this issue with connecting to the net.

Please post the output of:

inxi -F

This will help with a few questions. Apart from that, have you done any recent updates? — Today specifically.

I’m using my phone right now, and don’t know how to copy the output from my computer to my phone when it’s like this. The most I can think to do right now is to take photos of my screen.


I did update my computer twice yesterday, once before the internet problems, and once after, hoping an update would solve things.

If an update broke it, try downgrading the relevant packages to go back to where you were. I’m not sure what you updated, so I can’t tell you what to downgrade without more information.

Just discovered that turning on my VPN seems to allow me to connect, though I’m not sure why.

Check your router DNS settings.

It sounds like your VPN has a killswitch which has been set. Sometimes VPNs will enable this by default. It prevents any network activity from getting through without using the VPN connection. Often the killswitch will remain enabled even if the VPN is off.

1 Like

I thought the same thing too, but both the “VPN Kill Switch” and “Advanced Kill Switch” options are unticked in the settings of my VPN, which confuses me (though I suppose that’s more an issue with the VPN than EndeavourOS).

Maybe your problem is here:

Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
driver: r8169

Should it not be the r8168 driver?

I hadn’t actually noticed that myself until just now. How would I go downgrading the driver/getting the correct version installed?

You might want to consider adding:

 -z, --filter  Adds security filters for IP/MAC addresses, serial numbers, 
               location (-w), user home directory name, host name.

:male_detective:t5:

1 Like

I think you can do it in eos-welcome, otherwise check out:

https://discovery.endeavouros.com/network/r8168-workaround/2021/03/

Switched back to r8168, but that only seems to have caused more problems (I couldn’t connect even with the VPN active) but upon toggling back to r8169 I was able to connect again.

Thought things were okay for a bit, but did another update and now my wifi isn’t even showing up in the network manager. I can still connect to the internet using my ethernet cable, at least, but I’d like to know I have the wifi available still.

inxi -F -z gave me this:

System:
  Kernel: 6.8.2-arch2-1 arch: x86_64 bits: 64
  Desktop: Xfce v: 4.18.1 Distro: EndeavourOS
Machine:
  Type: Laptop System: Micro-Star product: GL75 Leopard 10SDR v: REV:1.0
    serial: <superuser required>
  Mobo: Micro-Star model: MS-17E7 v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends v: E17E7IMS.10C date: 11/17/2020
Battery:
  ID-1: BAT1 charge: 40.5 Wh (92.9%) condition: 43.6/51.6 Wh (84.6%)
CPU:
  Info: 6-core model: Intel Core i7-10750H bits: 64 type: MT MCP cache:
    L2: 1.5 MiB
  Speed (MHz): avg: 1359 min/max: 800/5000 cores: 1: 808 2: 800 3: 800
    4: 800 5: 800 6: 800 7: 3475 8: 800 9: 800 10: 4829 11: 800 12: 800
Graphics:
  Device-1: Intel CometLake-H GT2 [UHD Graphics] driver: i915 v: kernel
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] driver: nvidia
    v: 550.67
  Device-3: Chicony HD Webcam driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.11 driver: X:
    loaded: modesetting,nvidia dri: iris gpu: i915,nvidia,nvidia-nvswitch
    resolution: 1: 1920x1080~60Hz 2: 1920x1080
  API: EGL v: 1.5 drivers: iris,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.67
    renderer: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2
  API: Vulkan v: 1.3.279 drivers: nvidia,intel surfaces: xcb,xlib
Audio:
  Device-1: Intel Comet Lake PCH cAVS driver: snd_hda_intel
  Device-2: NVIDIA TU116 High Definition Audio driver: snd_hda_intel
  Device-3: Logitech Yeti Nano driver: hid-generic,snd-usb-audio,usbhid
    type: USB
  API: ALSA v: k6.8.2-arch2-1 status: kernel-api
  Server-1: PipeWire v: 1.0.4 status: active
Network:
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    driver: r8168
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: tun0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb type: USB
  Report: btmgmt ID: hci0 state: up address: <filter> bt-v: 5.2
Drives:
  Local Storage: total: 1.17 TiB used: 863.61 GiB (72.0%)
  ID-1: /dev/mmcblk0 vendor: SanDisk model: SDU1 size: 29.49 GiB type: USB
  ID-2: /dev/nvme0n1 vendor: Kingston model: OM8PDP3256B-AI1
    size: 238.47 GiB
  ID-3: /dev/sda vendor: Seagate model: ST1000LM048-2E7172 size: 931.51 GiB
Partition:
  ID-1: / size: 232.7 GiB used: 104.3 GiB (44.8%) fs: ext4 dev: /dev/nvme0n1p2
Swap:
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) file: /swapfile
Sensors:
  System Temperatures: cpu: 51.0 C pch: 52.0 C mobo: N/A gpu: nvidia
    temp: 48 C
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB available: 15.44 GiB used: 2.17 GiB (14.0%)
  Processes: 341 Uptime: 1m Shell: Bash inxi: 3.3.33

Your WiFi is intel chip using iwlwifi module.

Edit: In post 3 you show realtek rtw_8821cu which is a usb wifi adapter? This one is working?

Edit: You could try

sudo rmmod iwlmwm

sudo rmmod iwlwifi

sudo modprobe iwlwifi

The USB wifi adapter doesn’t seem to be working.
Tried the three commands you posted - when I did rmmod iwlmwm I got “Module is not currently loaded” and when I did rmmod iwlwifi I got ‘module is in use by iwlmvm’. When I did sudo modprobe iwlwifi I didn’t get a feedback message.

Have you checked this?

Gave it a try just now and it seems to be working, at least for the time being. If any other problems arise I’ll let you know.