Wi-Fi often randomly crashes or just slows down

My wifi experience in EndeavourOS has been very unstable, unfortunately. It often decides to become unusually slow (internet speed is meant to be 10 Mbps, and it often slows down to just 2 Mbps at most), and every so often the wifi connection just straight-up dies completely - as in, it’s not just that it can’t connect to my internet, but it straight-up can’t connect to any internet at all, with every single other wifi network displaying as having no signal. Every time it happens, the only way to solve it is to completely reboot my computer so the wifi works again.

I’ve tried to switch from the r8169 drivers to r8168 like Endeavour’s welcome screen suggested, but the issue is still present. And I know it’s not an issue with the internet itself; my phone’s still able to use the internet without issues, and the fact that all wifi connections display as having no signal is a sure-fire indicator that the problem isn’t just with my own internet. And I don’t think it’s my wifi antenna either, since I never dealt with this issue in Linux Mint.

I checked to see if NetworkManager is running via systemctl status NetworkManager.service, and it is. My wifi antenna, according to lsusb, is a “Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter”. I understand Realtek has terrible Linux drivers, but the model is actually from TP-Link, and once again, the wifi worked flawlessy in Linux Mint, so I’m not sure why it suddenly decided to not work on Endeavour.

What module is it using?
Edit2: The r8168 and r8169 are for your ethernet. I would use the r8169 kernel module and remove r8168 package if it works on r8169.

inxi -Na

Edit Did you have to install one of the package versions from the AUR to get it to work?


When I ran inxi -Na:

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8168 v: 8.049.02-NAPI modules: r8169
    port: f000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
  Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB
    driver: r8188eu bus-ID: 1-2:2 chip-ID: 0bda:8179 class-ID: 0000
    serial: 00E04C0001

And no, I haven’t installed any AUR packages for the drivers, I used it out of the box.

Well it looks like it has the module r8188eu already in the kernel then. If your ethernet works on r8169 then i would test that first and if it does then remove the r8168 package. So try your ethernet first on the r8169 module. If the ethernet works then you can remove the r8168 package. Then you can see if your WiFI is better or not? After that there may be some other things you can do maybe if it’s still not good.

sudo pacman -R r8168

There is no difference between the r8169 and r8168 drivers. I tried it on both of them, and both have the exact same issues; I only switched to r8168 because I was frustrated with having the issues on the r8169 and hoped downgrading would fix it.

You should switch then to r8169 and remove r8168 package and see if it is affecting the WiFi. You don’t need the r8168 package. On the new ISO we now have it as optional. The deafult is r8169. Only need the r8168 on certain chips if the r8169 doesn’t work properly or at all.

Edit: My ethernet has no problem using either module but i do know the one doesn’t come out of suspend mode and wake back up properly. But i don’t tend to use suspend much and or hibernate. It’s either on or off as it is a desktop.

From https://bbs.archlinux.org/viewtopic.php?pid=2008147#p2008147,

It could be that the in-kernel driver does not work well with your specific device, in which case blacklisting the kernel driver and trying one of the AUR drivers is a good next step.

(I’d probably try 8188eu-dkms first, then one or the other of the -git options.)

1 Like

I tried to install 8188eu-dkms through yay, but it threw an error;

:: Processing package changes...
(1/1) installing 8188eu-dkms                                 [--------------------------------] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Install DKMS modules
==> dkms install --no-depmod 8188eu/v4.3.0.8_13968 -k 5.15.10-arch1-1
Error! Bad return status for module build on kernel: 5.15.10-arch1-1 (x86_64)
Consult /var/lib/dkms/8188eu/v4.3.0.8_13968/build/make.log for more information.
==> WARNING: `dkms install --no-depmod 8188eu/v4.3.0.8_13968 -k 5.15.10-arch1-1' exited 10

I uploaded the make.log file on Paste.Debian because Pastebin is blocked by my ISP.

Looks like that one doesn’t support kernel 5.15. Try one of the others. :slightly_smiling_face:

1 Like

He/she could also try linux-lts, to check, if it solves the problem. :wink:

I tried switching to the LTS kernel, didn’t work. I tried compiling the other wifi driver, didn’t work. Hell, I tried reinstalling my system from the ground-up with the newest ISO refresh, and it didn’t work.

I’m out of ideas and frankly tempted to just give up and accept that I’ll be stuck with a throttled internet.

At this point I should probably look into getting a new Wifi USB, preferably one with open-source drivers that work well on Linux. I heard Mediatek has good Linux drivers, can anyone confirm that or at least give some other recommendations? Also, would it also work to put a Wifi Repeater on my room and then connect it to my computer with an ethernet cable? We have an unused repeater lying around here that has an ethernet cable slot, but I’m not sure if it’d be a good idea to try that. (I’m not even sure if the slot is to connect a computer to it, it might be to connect the router to the repeater.)

1 Like

There is no harm in trying the repeater. It’s just a bit of time involved and maybe some new learning. I would suggest you use the r8169 kernel module and uninstall the r8168 package for the Ethernet.

Also did you try this package?


I haven’t had luck with the AUR version of that driver either, sadly, but I did manage to get this resolved in an unorthodox way.

Turns out we had a spare 5G wifi antenna lying around, and I was allowed to use it. It’s also from TP-Link and therefor also uses Realtek drivers sadly, but a quick DuckDuckGo search sent me to an AskUbuntu thread with someone also using that wifi antenna and not having drivers for it, and someone posted a link to the GitHub page of aircrack’s drivers for that antenna (which is the rtl8812au rather than the rtl8188eu). I installed and compiled it, and not only is the internet working and the Wifi USB being recognized, I also am getting far faster internet than before! No words on how stable it is yet sadly, since I just started using it, but hopefully it’ll actually be stable and not randomly kill itself ^^’

So far the only issue I’m having is that, for some reason, our 5G internet isn’t showing up in the network list (and only our 5G; other 5G wifi spots show up just fine), so I’m stuck using 2G for now anyway. I have no idea why this is the case and hope that it’ll go away with a reboot. Still, going from less than 1 Mbps of speed to nearly 50 Mbps is wonderful.

1 Like

Wow …I’m impressed! :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.