Wi-Fi driver randomly glitching every hour after startup

So while the fix didn’t outright get rid of the problem, it made it more manageable. Now it happens a long time after startup, and turning the wifi on and off before it has the chance to fully disconnect seems to work almost like a jumpstart or a defibrillator.

I’ll try the power save config and hopefully, it will make it more tolerable.

Considering that this is already a known kernel bug, I think it’s best if I just mark it solved since it relies on the kernel devs to fix it in the next patch.

Thank you.

EDIT: The power saver borked the network daemon. Getting rid of the power saver config un-borked the daemon. WTF?

EDIT: My idiot-self forgot to add the [connection] flag at the top. This does indeed work.

1 Like