Why do HP printer drivers suck when I'm the one using them?

Gather round, and let me tell you my tale of printer woe.

My first printer on Linux was a Brother laser printer, and it worked well for me on both Windows and Ubuntu for about 8 years or so (until it began lighting paper on fire instead of print it it). I replaced this one with a HP Laser printer (forget exact model name) and oh boy, it was a complete mess to configure.

It soon became apparent that HP provided pretty good support for some of their models, and not others. I managed to it to work somehow, until one day after I upgraded to the latest Ubuntu version it refused to work at all. Shortly after this, I moved to EndeavourOS and the issue persisted.

I decided to replace it with a more modern HP Laser MFP 13x series which also had an onboard scanner, promised wireless printing and appeared to have good Linux support. Maddeningly it had the same problem.

HPLIP supports about 99% of printers extremely well (when I search Google, it appears that literally nobody on the internet has had my experience), and both of my printers appear to be in the 1% that are barely supported.

My printer is wireless, but when I type “hpsetup” into Terminal it did not detect my printer. My printer is also not in the list of supported HP devices on CUPS.

“Oh fine, but what about generic printer drives, you say?” HAHA. Yes, CUPS detected my printer but once I set it up it was all: " Unsupported format application/vnd.cups-pdf-banner", baby. Ghostscript and cups-filter were both installed, and offered no help at all.

According to some obnoxious and condescending posts on another forum, printer drivers are so last century and my printer should be able to operate “driverless”. However, when I tried a driverless set up it printed 50 pages of garbage ASCII along the margins of the pages. Driverless printing sure sounds good, but the way my printer chooses to interpret it, driverless means that is in the driving seat and can print any old random collection of letters, numbers and symbols it chooses to.

Finally, I discover the existence of and am able to install the hpuld package from AUR, which is out of date, but actually supports my printer. As it is out of date, I had strong misgivings but well what other choice do I have? While setting up the printer, CUPS bluntly informs me that drivers are so last century and they will not support printer drivers in future versions - oh dear.

The first direct result of installing these drivers was that my printer was no longer discoverable (uh, oh). I reset network manager and CUPS and it was discoverable - panic averted. Finally, four hours later I was able to configure my printer. Out of those four hours, I spent 3 resisting the urge to smash my printer. Thanks to patience, perseverance and no thanks to HP at all, I finally have a working device.

So what can I say? It at least appears that HP offers great driver support on Linux, however my luck in that regard has been nothing short of terrible. It also does appear that they did - at one point - create drivers that supported my device, but that they’re out of date (which is infuriating as I ordered my printer two weeks ago). Contrast this with when I got my Dad (Ubuntu user) a Brother printer last October, Ubuntu detected it right out of the box and no configuration was needed. Lest anyone say that this is because it was a n00b OS, and Endeavour being Arch and all provides more of a challenge - my wife’s Ubuntu laptop also had a very hard time detecting and configuring my HP printer, and had no such issue when I tested my Dad’s Brother printer on it. The only difference is that HP offers Ubuntu-compatible drivers on its website.

Has anyone else had a similar experience with HP printers?

1 Like

Printer detection can be a bit tricky because hplip offers multiple options and which ones work and don’t work will depend on your network and firewall config.

Other than that, I haven’t had major issues with several different HP printers.

The network and firewall were configured fine in my case, the printer was not supported by hplip - which means I cannot comment on how hplip works for others.

I was under the mistaken impression that hplip provided support for all HP printers, which is clearly not the case.

I’ve actually had pretty good experiences with HP printers, but always check compatibility before purchasing.

This is a mistake I will never make again (until next time).

1 Like

Sorry to hear about your frustration. That’s really unfortunate that it’s no longer fully supported.

1 Like

The arch wiki shows that multifuntion laser printers may require hpuld


1 Like

That’s correct, and it’s what finally got it to work. The AUR package is out of date though and was slightly tricky to install.

1 Like

I feel your pain. I have had very very VERY poor experiences setting up printers in Arch based distros. Every single time is awful. I’ve still never been able to print wirelessly. Fedora? No problem, literally worked out of the box. I’ve followed tutorials. I’ve tried on my own. I’ve had folks walk me thru it. Nothing.

I completely understand your HP printer hatred.

1 Like

My HP laserjet printer setup was easy but seems to stop working at every (kernel?) update. Never figured what it was but the only fix was to reinstall the printer again. That’s something painful with arch and haven’t figured it out yet.

1 Like

Sometimes using a “bleeding edge” distro means it’s your turn to bleed. :joy:

1 Like