Whitenoise while playing audio

There is strange whitenoise coming from the speaker whenever I play some audio. The audio itself isn’t audible. I only hear whitenoise. The loudness of this whitenoise isn’t affected by my system volume. The whitenoise starts the moment grub boots, and continues till the lightdm login page. After that the noise comes only when some audio is being played. The noise is also there if I use earphones instead of laptop speaker - the noise comes through earphones rather than speaker. This problem occurred after today’s update. Downgrading linux kernel didn’t help. The problem is with both linux lts and linux kernel.

I have tried 2 things:

  1. Adding these to /etc/modprobe.d/modprobe.conf
options snd_hda_intel power_save=0
options snd_hda_intel power_save=0 power_save_controller=N
  1. Adding this to /etc/pulse/default.pa
load-module module-udev-detect tsched=0

I also muted mic from pavucontrol but that didn’t help.

Output of journalctl -b --user-unit=pulseaudio

-- Journal begins at Tue 2021-01-19 17:57:40 IST, ends at Tue 2021-01-19 18:21:56 IST. --
Jan 19 17:57:59 wired systemd[995]: Starting Sound Service...
Jan 19 17:58:00 wired systemd[995]: Started Sound Service.
Jan 19 17:58:00 wired pulseaudio[1054]: GetManagedObjects() failed: org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.bluez.service not found.

The last line appears in red color :point_up:

This is how alsamixer looks like

inxi -Fxxa

System:    Host: wired Kernel: 5.4.89-1-lts x86_64 bits: 64 compiler: gcc v: 10.2.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux-lts
           root=UUID=f1f86514-4df2-422c-8a7a-1ad2b16e1013 rw quiet loglevel=3 nowatchdog
           Desktop: i3 4.19 info: polybar dm: LightDM 1.30.0 Distro: EndeavourOS
Machine:   Type: Laptop System: Dell product: Inspiron 3493 v: N/A
           serial: <superuser required> Chassis: type: 10 serial: <superuser required>
           Mobo: Dell model: 0F9NFW v: A00 serial: <superuser required> UEFI: Dell v: 1.13.0
           date: 11/13/2020
Battery:   ID-1: BAT0 charge: 34.2 Wh condition: 42.0/42.0 Wh (100%) volts: 12.3/11.4
           model: SWD-ATL3.618 DELL WJPC406 type: Li-ion serial: 27829 status: Unknown
CPU:       Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake
           family: 6 model-id: 7E (126) stepping: 5 microcode: A0 L2 cache: 6 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19046
           Speed: 1083 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 1083 2: 1101 3: 1100
           4: 1100 5: 1100 6: 1100 7: 1080 8: 1100
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1
           mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel
           bus ID: 00:02.0 chip ID: 8086:8a56
           Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-6:2
           chip ID: 0bda:5675 serial: 200901010001
           Display: x11 server: X.org 1.20.10 driver: intel unloaded: fbdev,modesetting,vesa
           resolution: <missing: xdpyinfo>
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel Smart Sound Audio vendor: Dell driver: snd_hda_intel v: kernel
           alternate: snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:34c8
           Sound Server: ALSA v: k5.4.89-1-lts
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: N/A
           modules: r8169 port: 3000 bus ID: 01:00.0 chip ID: 10ec:8136
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell
           driver: ath10k_pci v: kernel port: 3000 bus ID: 02:00.0 chip ID: 168c:0042
           IF: wlan0 state: up mac: 28:cd:c4:74:a1:b3
Drives:    Local Storage: total: 1.14 TiB used: 171.38 GiB (14.6%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 model: CL1-3D256-Q11 NVMe SSSTC 256GB
           size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
           lanes: 4 serial: TW0TN2CC9DH0006B084N rev: 22301114
           ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-75Z10T3
           size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
           serial: WX22A60FFN2D rev: 4514
Partition: ID-1: / raw size: 237.97 GiB size: 233.24 GiB (98.01%) used: 20.11 GiB (8.6%)
           fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-2: /boot/efi raw size: 512 MiB size: 511 MiB (99.80%) used: 12.4 MiB (2.4%)
           fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:      Alert: No Swap data was found.
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 194 Uptime: 19m wakeups: 1 Memory: 7.55 GiB used: 2.33 GiB (30.8%)
           Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1036 lib: 299
           Shell: Zsh v: 5.8 running in: alacritty inxi: 3.2.01

Please tell any other output I need to share.
Thanks

Edit: Problem is there in windows 10 too. Can it be some hardware problem?

Edit 2: The whitenoise is there even when I am in the bios settings. I have disabled my speaker via the bios and that works as a temporary workaround for now. No whitenoise. I am using earphones. I am just curious about exactly what could’ve happened in an update.

Yes. Could be a bad or worn (wet) connection.

Check which packages were updated.

1 Like

from the log this is what happened during the last update:

[2021-01-19T16:01:42+0530] [ALPM] upgraded libibus (1.5.23+3+gaa558de8-2 -> 1.5.23+3+gaa558de8-3)
[2021-01-19T16:01:42+0530] [ALPM] upgraded kid3-common (3.8.4-1 -> 3.8.4-2)
[2021-01-19T16:01:42+0530] [ALPM] upgraded kid3-qt (3.8.4-1 -> 3.8.4-2)
[2021-01-19T16:01:42+0530] [ALPM] upgraded lib32-sdl2 (2.0.12-1 -> 2.0.14-1)
[2021-01-19T16:01:42+0530] [ALPM] upgraded libbytesize (2.4-3 -> 2.4-4)
[2021-01-19T16:01:42+0530] [ALPM] upgraded libblockdev (2.24-3 -> 2.25-1)
[2021-01-19T16:01:43+0530] [ALPM] upgraded linux (5.10.7.arch1-1 -> 5.10.8.arch1-1)
[2021-01-19T16:01:45+0530] [ALPM] upgraded linux-headers (5.10.7.arch1-1 -> 5.10.8.arch1-1)
[2021-01-19T16:01:45+0530] [ALPM] upgraded linux-lts (5.4.89-1 -> 5.4.90-1)
[2021-01-19T16:01:47+0530] [ALPM] upgraded linux-lts-headers (5.4.89-1 -> 5.4.90-1)
[2021-01-19T16:01:48+0530] [ALPM] upgraded python-setuptools (1:51.1.2-1 -> 1:51.2.0-1)
[2021-01-19T16:01:48+0530] [ALPM] upgraded r8168 (8.048.03-57 -> 8.048.03-58)
[2021-01-19T16:01:48+0530] [ALPM] upgraded wine-gecko (2.47.1-1 -> 2.47.2-1)
[2021-01-19T16:01:48+0530] [ALPM] upgraded xfce4-appfinder (4.16.0-1 -> 4.16.1-1)

The only package that could be the culprit here is the kernel. And downgrading the kernel didn’t help.

This is a laptop purchased in dec 2020, and I haven’t spilled any liquid over it. The weather isn’t humid either, so I think I can rule out this one.

So basically the kernel was the only related update. Can’t see that affecting the hardware?

You could try downgrading the kernel, or using one of the older LTS kernels to rule out a kernel update?

That doesn’t rule out a bad or broken connection.

Given this happens in the BIOS it does seems like a hardware issue (or Windows has blocked the hardware into an “on” state).

2 Likes

Okay I will try. Right now I cannot reboot since I’m in middle of an online workshop.

I don’t boot into windows. Its just lying on the HDD. Everything was fine until the update on EnOS today. I rebooted since it was kernel update and I was supposed to be working with virtual box. After the reboot white noise started pouring out from the speaker.

Looking on the web, there are multiple similar reports on Dell community about XPS laptops. (Mine is an Inspiron). I will try system update via Windows, if there is some firmware update available.

Thanks

Edit:
Just in case I was unclear, I don’t boot into Windows usually. But today I did boot to check if the problem was linux exclusive or if it persisted otherwise too.

1 Like

Thanks for you time @jonathon :pray:

Re-enabling the speaker from bios setting, the white noise is not coming anymore.
I downgraded the kernel, and upgraded it back to the latest. The white noise doesn’t re-appear.

So basically what worked for me was to disable speaker from bios, reboot and enable it again. I believe this might have “resetted” some speaker setting in the bios (if something like that exists). Still don’t know why the problem was caused in the first place.

Anyways, the laptop is back to normal now. I guess that is more than enough for me.

3 Likes