White screen with standard linux kernel

Hi guys, my endeavouros is not booting anymore with the standard linux kernel. White screen. I have the problem since severl weeks. The linux-lts kernel works fine fortunately. Graphics driver is nouveau. Could someone help me eliminate the cause? Thanks in advance

Let’s try.
First, please post the output of commands

inxi -zaG
nvidia-inst --test

inxi -zaG
Graphics:
Device-1: Intel 4th Gen Core Processor Integrated Graphics
vendor: CLEVO/KAPOK driver: i915 v: kernel arch: Gen-7.5 process: Intel 22nm
built: 2013 ports: active: eDP-1 empty: HDMI-A-1,VGA-1 bus-ID: 00:02.0
chip-ID: 8086:0416 class-ID: 0300
Device-2: NVIDIA GM107M [GeForce GTX 860M] vendor: CLEVO/KAPOK
driver: nouveau v: kernel non-free: 535.xx+ status: current (as of 2023-09)
arch: Maxwell code: GMxxx process: TSMC 28nm built: 2014-19 pcie: gen: 1
speed: 2.5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:1392 class-ID: 0302 temp: 59.0 C
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
compositor: xfwm v: 4.18.0 driver: X: loaded: intel,modesetting
alternate: fbdev,nouveau,nv,vesa dri: i965,nouveau gpu: i915
display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP1 model: Chi Mei Opto 0x1720 built: 2011
res: 1920x1080 hz: 60 dpi: 128 gamma: 1.2 size: 380x210mm (14.96x8.27")
diag: 438mm (17.3") ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel crocus drv: nvidia nouveau platforms:
device: 0 drv: crocus device: 1 drv: nouveau device: 2 drv: swrast gbm:
drv: crocus surfaceless: drv: nouveau x11: drv: crocus inactive: wayland
API: OpenGL v: 4.6 compat-v: 4.3 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 4600 (HSW
GT2) device-ID: 8086:0416 memory: 1.46 GiB unified: yes

nvidia-inst --test
bash: nvidia-inst: Kommando nicht gefunden.

Do you want to keep the nouveau driver or install the proprietary Nvidia driver?

If nouveau, then I think an option is to wait for a fix from the kernel updates and keep using the LTS kernel for now.

If Nvidia, then you can install nvidia-inst, the program that helps installing the driver:

sudo pacman -S nvidia-inst

and then run the command

nvidia-inst --test

This shows the commands that nvidia-inst would run to install Nvidia driver.
It should give a starting point.

Probably a good idea is to look at the options of nvidia-inst:

nvidia-inst --help

You can try installing with just

nvidia-inst

and reboot.
If that fails, you can get nouveau back with

nvidia-inst --nouveau

Note:

  1. Be sure to backup all personal data before doing anything else. This is always the best practice.
  2. It is a good idea to keep the LiveUSB ready if booting fails. Then you can do necessary recovery operations.

I have a laptop with quite similar specs (Intel/Nvidia GF108 graphics combo, 3rd gen Core i7 processor) and also noticed a white screen (white with some colored static on top) at boot after updates.

For me, it turned out that it only happened at cold boot, maybe some initialization error? This is a triple-boot system, so a warm boot coming from the second Linux system made the issue irrelevant for me.

Mabe worth a try to see if a warm boot from a live iso or whatever fixes it for you as well.

I will keep nouveau for now. I hope they work on it. Thanks for the help.

1 Like

You are right with the warm boot but…
I basically tried it four times. It seems that the warm-boot from linux-lts kernel to linux kernel works. But the warm-boot from linux kernel to linux kernel does not.

I also have a trible-boot system but have not tried the boot from the other distributions as they are not up to date anyway.