When streaming, monitor goes to sleep

This has started happening the last month or so. I haven’t been able to pin down why it started.

It’s not random, it’s the same amount of time (about 8 minutes) and it’s that the screen goes to sleep due to it thinking the computer is idle.

I run i3wm and have commented out my setting for setting the monitor idle time. That did not solve this issue. I’m using firefox.

It happens when streaming netflix and a Swedish channel.
This did not happen before on either of these.

Any ideas?

Does this 8 minutes correspond to the setting in your config for monitor idle time?

What’s the output of xset -q?

It is a known Firefox issue that screensavers will be activated even when you are streaming a video. There was a fix for this, but it only applies when you watch the video in fullscreen (did you?)

Does the issue also occur on a different browser?

It did. But, due to ads it is of course 10 minutes. 8 minutes (or such) of the actual show, rest ads.

Output is:

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  660    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  built-ins
DPMS (Display Power Management Signaling):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Enabled
  Monitor is On

It seems like it still is set to 600 seconds.

I have the following in my i3 config file:

# set powersavings for display:
# exec --no-startup-id xset s 480 dpms 600 600 600

So, it’s strange that it’s set to turn monitor off anyway.

I did watch it in fullscreen yes.

I have not checked yet. Will try that next time.

I had this problem in Gnome. Installing Espresso extension stopped it.



for kde

Thanks for the suggestions but I run i3wm and not gnome or KDE. :slight_smile: