When my screen turns off due to idle, it doesn't turn back on no matter what I do

Hey so I recently upgraded to the latest KDE version that uses wayland and ever since then, when my screen turns off due to idle, it doesn’t turn back on no matter what I do.

I am running an RTX 4090 with the following inxi -G output:

Graphics:
  Device-1: NVIDIA AD102 [GeForce RTX 4090] driver: nvidia v: 550.54.14
  Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: nvidia unloaded: modesetting
    gpu: nvidia resolution: 2560x1440
  API: EGL v: 1.5 drivers: nvidia,swrast,zink
    platforms: gbm,wayland,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.54.14
    renderer: NVIDIA GeForce RTX 4090/PCIe/SSE2
  API: Vulkan v: 1.3.279 drivers: nvidia surfaces: xcb,xlib,wayland

Would appreciate help on this.

My monitor is also an OLED monitor so I don’t think this is any sort of backlight issue.

Hello athecoder. Welcome to the forums!

I had this problem recently and this is what worked for me, so maybe it works for you?

System Settings → Power Settings (change default settings and ‘Apply’ and then change them back!)

After a period of inactivity: sleep

Under Display and Brightness: (check all boxes)

click apply in the bottom corner of the window.

then uncheck all the boxes under Display and Brightness.

Set After a period of inactivity: Do nothing

click apply in the bottom corner of the window.

Hey @Melways, Thanks.

Well this might solve the issue. However me using an OLED screen I actually need the screen to turn off after a certain time.

I think its not really a good idea to disable this functionality just because it is buggy. Maybe there is a way to fix this while also having screen timeout?

So… Why not do all the above and then set the settings you would like. Nothing to be scared of.

I think it is because there are missing settings in a configuration file somewhere, but as of writting i haven’t located the file.

I’m assuming this is on latest and lts kernels?

Yes it is. Latest Nvidia Drivers and Kernel and everything. Updated yesterday.

But changing the settings didn’t help. It is still happening

@athecoder you tried the LTS kernel right ?

Well… what about:

sudo nano /etc/modprobe.d/nvidia-power-management.conf

Do you have this line:

options nvidia NVreg_PreserveVideoMemoryAllocations=1 NVreg_TemporaryFilePath=/var/tmp

If it is not there add it. Hold ctrl and tap o. Then press enter to save.
Hold ctrl and tap x to quit the editor.
Now reboot.