What to do when this happens?

A few days ago i tried to install EndeavourOS with the latest iso and it wouldn’t boot. Later today i figured it out what was the problem. That specificic LTS kernel version can’t boot with my pc.
What could i do to workaround this in case something like this happens again?

Dont use rhe LTSk ernel?

1 Like

No i usually don’t

If you can’t boot due to a temporary kernel regression. . .

You can use another kernel. You can roll a backup and update again later. Or you can fix the kernel yourself. . . Although if you actually know how to fix the kernel, it’s unlikely you’re asking for our help.

He wrote, he tried to install EndeavourOS with the latest ISO, but he couldnt, because the ISO dont boot with the Kernel build in it.

Thats how i understand it. Do the ISO use a specific LTS Kernel? Dont know. Must check it.


Started a ISO in a VM:

Linux EndeavourOS 5.15.8-arch1-1 #1 SMP PREEMPT Tue, 14 Dec 2021 12:28:02 +0000 x86_64 GNU/Linux

The ISO uses a mainline kernel.

So, did you actually TRIED to install, or could you install and boot it, you only installed the LTS kernel for what ever reason? @lighttigerXIV

Your question is confusing. You say you tried to install eos but it didn’t boot. ISO live ships with the mainline kernel as default it doesn’t use or have the LTS kernel.

So did you or didn’t you install eos on your computer and install the LST Kernel then try to boot using the LTS?

LTS kernels don’t support some new hardware until they get passed through the mainline.

If the problem is your kernel workaround is to switch to another kernel. That’s why many here have bot mainline and LTS kernels installed. We use LTS as our daily driver kernel and use the mainline as the backup.

But truly the question is kind of confusing. Also, it would help if you could post the output of the below command.

inxi -Fxxc0z --no-host | eos-sendlog

You’ll get a link post it here so the community can have a better understanding of your system.

Is confusing for sure because there is no lts kernel on the ISO. So the OP is in fact doing something other than what is written.

I’m quite aware of what they wrote. .iso ships with the latest kernel, not lts, so they couldn’t have figured out the lts doesn’t boot if it’s a live iso. . .

English isn’t everyone’s first language, sometimes here we need to read into it a little further.

Lose the snarkiness, it’s getting old.


If you don’t have the latest kernel installed currently, you can follow this here to chroot and install the latest kernel.


pacman -Syu linux linux-headers

Update your grub, and you should be good on the main kernel again.

1 Like

For everyone that is confused…
Some days ago i needed to install EndeavourOS and downloaded the latest iso but it couldn’t boot at all, the screen went black after i booted and it got stuck there. What i did after was asking for and older iso and the dev gave me a link to a previous one (thankfully). After that i managed toinstall EndeavourOS and all is working fine like it should.

Yesterday i installed LTS kernel just for having it and i tried to boot with it and the same behaviour happened so i just assumed the iso was booting with LTS kernel.

My question was if it was possible to change the kernel in that iso so that i could boot to it. (Like going to terminal before the it boots, like the grub terminal) Im asking this just in case this happens again.

And i couldn’t know what kernel the iso was using since i couldn’t boot XD

That sounds more like a graphics driver problem to me than a kernel problem. Are you trying to boot with the proprietary nvidia drivers?

Two questions for now:

  1. Could you send information about your machine:
inxi -Faz | eos-sendlog
  1. Which menu entry did you choose for booting the ISO?

The result from inxi:

  Kernel: 5.15.12-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux
    root=UUID=4f5635fc-dcdc-470e-a234-305a65a484d1 rw quiet loglevel=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1
    dm: LightDM 1.30.0, SDDM Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: LENOVO product: 82JU v: Legion 5 15ACH6H
    serial: <superuser required> Chassis: type: 10 v: Legion 5 15ACH6H
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN
    serial: <superuser required> UEFI: LENOVO v: GKCN40WW date: 07/18/2021
  ID-1: BAT0 charge: 82.5 Wh (100.0%) condition: 82.5/80.0 Wh (103.2%)
    volts: 17.3 min: 15.4 model: Celxpert L20C4PC1 type: Li-poly
    serial: <filter> status: Full cycles: 10
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: Discharging
  Info: model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 2569 high: 3000 min/max: 1200/3300 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2616 2: 2687
    3: 2883 4: 2975 5: 2796 6: 2560 7: 2222 8: 1936 9: 2335 10: 3000 11: 2101
    12: 2726 bogomips: 79080
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Lenovo
    driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
    chip-ID: 10de:2560 class-ID: 0300
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-3:3 chip-ID: 174f:2459 class-ID: fe01 serial: <filter>
  Display: x11 server: X.org compositor: kwin_x11 driver:
    loaded: nvidia unloaded: fbdev,modesetting,vesa alternate: nouveau,nv
    resolution: <missing: xdpyinfo>
  OpenGL: renderer: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2
    v: 4.6.0 NVIDIA 495.46 direct render: Yes
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
    chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
    vendor: Lenovo driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x bus-ID: 05:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.12-arch1-1 running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8168 v: 8.049.02-NAPI modules: r8169 port: 2000
    bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Realtek vendor: Lenovo driver: rtw89_pci v: N/A
    modules: rtw89pci port: 1000 bus-ID: 04:00.0 chip-ID: 10ec:8852
    class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-4:3 chip-ID: 0bda:4852 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 39.08 GiB (8.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLB512HBJQ-000L2 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 3L1QEXF7 temp: 32.9 C scheme: GPT
  ID-1: / raw-size: 225.26 GiB size: 220.66 GiB (97.96%)
    used: 39.08 GiB (17.7%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%)
    used: 296 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p6 maj-min: 259:6
  Alert: No swap data was found.
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 31 C
  Fan Speeds (RPM): N/A
  Processes: 337 Uptime: 3h 40m wakeups: 6 Memory: 7.68 GiB
  used: 4.99 GiB (65.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: 1250 pacman: 1240 lib: 327 flatpak: 10 Shell: Bash
  v: 5.1.12 running-in: konsole inxi: 3.3.11

I don’t know why but i couldn’t choose the boot option to got with nvidia drivers.

Not sure of this works with the nouveau driver… does anyone here know?
But that might explain why it didn’t boot with the ISO.

Next question is, why you couldn’t choose the boot entry with Nvidia drivers…
Changing the kernel options in the Nvidia boot entry could help, if possible.

i didn’t mean to be snarky, i just thought maybe you misunderstood. that wasn’t meant to be mean or “judge” anyone.

At the time I myself did not know which kernel is used, so I quickly looked up, and then also found that the question is confusing.

When you get to the black screen can you change your framebuffer to get a login prompt by pressing CTRL+ALT+F3?

I did try that at the time but nothing happened.

Can someone close the thread? This is getting confusing XD

1 Like