Welcome mirror update problem

I just tried to update my netbook. Due to some 404 errors I tried to update the mirrorlist using Welcome. This didn’t work, so I used reflector-simple to get an actual mirrorlist. This worked flawlessly. After this I updated the whole system using yay. After rebooting the system the error in Welcome still persists.Didn’t have any issues when updating my Desktop.

Error: configuration 'eos-run-cmd-with-su' for EOS_ROOTER in file /etc/eos-script-lib-yad.conf is not supported!

Any idea what is causing this?

Maybe you haven’t updated the configuration files with eos-pacdiff?
Especially /etc/eos-script-lib-yad.conf seems to be old.

1 Like

Is there a way to fix it? Welcome doesn’t even offer option for pacdiff & kdiff3. I ran eos-pacdiff with no output at all. Still not getting the whole pacnew/pacdiff concept. I was sure I had pacdiff-pacman-hook-git (which should automatize the process) installed on my Netbook. Unluckily this assumption was wrong. It is installed on my Desktop, which might be the reason for being no problems on this one at all.
I know, that /etc/eos-script-lib-yad.conf is part of eos-bash-shared.

You can manually check for pacnew files; assuming you have meld installed (meld is arguably the simplest / easiest to use viewer for diffs), run:

sudo DIFFPROG=meld pacdiff

If you get no return, that would mean that there are no pacnew files on your machine.


Thanks for your suggestion. I’ll have a look at it. Can’t work for too long at my computer right now, due to pain in back and sciatic nerve. Have to take longer breaks at the moment. :wink:

Which one of the options would be the one to take?
view and skip wouldn’t change anything → no effect at all
remove pacnew or overwrite with pacnew?
I guess overwriting should be the correct choice, because removing pacnew would not apply any changes.

view will show you what is different between the old file and the pacnew.

You can merge changes from the pacnew to the old file, or the other direction.

Simply deleting a pacnew file will mean that any new configurations will be unavailable to you; overwriting will mean that any changes you made to the old file will be lost. What you want to do is merge any important changes.

However, with files that involve your user setup and passwords, the pacnew files will be blank templates - be very careful. This would be files like shadow, passwd, gshadow, group. Never overwrite these files with pacnews.

There is no one answer for handling pacnew files; it depends on what changes have been made. That’s why you should view the diffs, compare what has been changed, and then act on them.

Thank you. Sounds like I’m going to have some fun tonight. :wink:

1 Like

Just a tip - you might want to make a copy of both the original file and the pacnew before you do anything. That way, if you should make a monumental error, you will still have both the original, untouched file and the original pacnew.

Once you get some experience and confidence handling them, you might skip making backup copies, but it’s a really good idea to do so the first time around.

Especially files like /etc/eos-*.conf need to be merged (so don’t merge blindly if you have changed any configurations… :wink:) to solve this particular problem.

Others you can deal with later, when you have more time and opportunity to concentrate on them.


After melding all available configs, it still didn’t work. So I took the sledgehammer approach. I removed 7 packages from EOS repository and deleted all eos-*.conf files in /etc. After reinstalling the packages from EOS repository, everything works like expected.
Maybe not for writing down in a HowTo, but it did work for me right now. I haven’t made many (if even any at all) changes to those configs.

Thanks for the support.

1 Like

That is one way of solving the problem! :wink:

But in general, it is a good idea to occasionally check config file changes as well.
And program eos-pacdiff is meant for that.

Essentially it does what @Stagger_Lee mentioned:

  sudo DIFFPROG=meld pacdiff

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.