Welcome Assistant

Welcome app has now a new tab called Assistant. (Thanks @freebird54 :smile: !)

The Assistant contains tools for generally useful and/or daily tasks.
As you probably notice, the buttons under this tab are familiar mostly from the After Install tab.

This separation makes sense because users familiar with the Welcome app probably have already made certain settings and want to use mostly the stuff of the Assistant tab.

Here’s a picture of the new Assistant tab:

The new After Install tab looks like this (under Xfce):

There’s a new button: Select initial Welcome tab.

initialtab

This new button allows user to change the default tab that is always shown when Welcome is started. The idea is that seasoned users can easily change the default tab to Assistant (or any other tab).

The role of the After Install tab now becomes more like the settings toolset right after install. Most of these changes are typically done only once, or quite seldom anyway.

17 Likes

Awesome. Thank you @manuel @freebird54 :enos_flag:

1 Like

Keeps getting better!

It is not working for me. Every time I want to change the initial tab from 2 to 3 the welcome app closes after pushing the OK button and reopens with tab 2 as default.
Welcome app v3.12.11-1

I’ve tried as few others as choices - still get 2 as a result. Nothing in the .conf about it either? Bound to be a ‘late night style’ ooops! :grin:

What’s the contents of file ~/.config/welcome.conf?

It’s not working for me either.

local ConfVersion=1.1.8-1
local MaxButtonNameLength=40
1 Like

OK, there’s the reason.
That is an old config file.

The contents should be like this:

$ cat ~/.config/welcome.conf
EOS_WELCOME_ACTIVE_TAB_NUMBER=2

So you can just delete that file, and then it should work.

Thanks all for the report! I should make a new version that checks if there is the old config file is still around and just deletes it.

1 Like

Delete the whole file or just what’s inside?

The whole file.

Now it works! :grinning_face_with_smiling_eyes:

1 Like

Version 3.12.12-1 fixes this issue.
It will be in the mirrors within 0 to 2 hours depending on the mirror.

1 Like

I just updated it now. :grinning_face_with_smiling_eyes:

1 Like

You are using the Alpix mirror?

Maybe on this system? I check my pacman.conf?

Edit: Sorry my mirror list!. That would be the endeavouros mirror list?

Yes, the endeavouros-mirrorlist.

Nope! Not there. Just the github mirror.

Edit:

Hmm… I thought it was the new one? :thinking:

Ah I see. That gets stuff first, but Alpix is only a minute or two behind.
Others are more or less 1 to 2 hours behind.

No, that’s the old one. But if you deleted the config file, no problem.

Sorry i messed up and i did get it. I was in a vm and clicked on the host. Now i got on the host too.

Edit:

1 Like